summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrLi2021-11-05 01:29:06 +0800
committerBrLi2021-11-05 01:29:06 +0800
commit61d28d487a08fca097d89fb620a5aec28dc137f6 (patch)
tree3252ba393b13ec692249d7eab289e6200a7c289d /PKGBUILD
parentc0842918f0392004b2a38a0b00bf1ebbb67265e6 (diff)
downloadaur-61d28d487a08fca097d89fb620a5aec28dc137f6.tar.gz
updpkg
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2fe7288f9bad..1043f0ac277f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@
_bundle_pandoc=false
pkgname=zettlr
-pkgver=2.0.1
-pkgrel=3
+pkgver=2.0.2
+pkgrel=1
pkgdesc="A markdown editor for writing academic texts and taking notes"
arch=('x86_64')
url='https://www.zettlr.com'
@@ -26,7 +26,7 @@ source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Zettlr/Zettlr/archive/v
# citation style
"locales-${pkgver}-${pkgrel}.zip::https://github.com/citation-style-language/locales/archive/${_csl_locale_commit}.zip"
"chicago-author-date-${pkgver}-${pkgrel}.csl::https://github.com/citation-style-language/styles/raw/${_csl_style_commit}/chicago-author-date.csl")
-sha256sums=('281747d7f123164f94f5878fb98ae48616a902e5be2cfdea2bfe3d859253463d'
+sha256sums=('143c73c6b92a2e2b67ba99825b06453da36bb6bede4040c2bdec6d47187641ae'
'a0fe981dade0ce52be190d8e8a2fd7f6c05c32c7d44d96c63f6f494460d483ef'
'9b3e987aefb10da8b2baadd06e751e978ea23dc7b6297802cbda0ec6806744e2'
'1455e57b314fd13ba155f4ab93f061e3e6393c13cd0f16380adb9d73614f7930')
@@ -115,7 +115,7 @@ package() {
cp -r --no-preserve=ownership --preserve=mode ./package.json "${pkgdir}/${_destdir}/"
# Install start script to /usr/bin
- install -Dm755 /dev/stdin "${pkgdir}/usr/bin/${pkgname}" <<END
+ install -Dm755 /dev/stdin "${pkgdir}/usr/bin/Zettlr" <<END
#!/bin/sh
exec electron /${_destdir} "\$@"
END
@@ -123,25 +123,25 @@ END
# install icons of various sizes to hi-color theme
for px in 16 24 32 48 64 96 128 256 512 1024; do
install -Dm644 "${srcdir}/Zettlr-${pkgver}/resources/icons/png/${px}x${px}.png" \
- "${pkgdir}/usr/share/icons/hicolor/${px}x${px}/apps/${pkgname}.png"
+ "${pkgdir}/usr/share/icons/hicolor/${px}x${px}/apps/Zettlr.png"
done
# generate freedesktop entry files, aligned with description in package.json and forge.config.js
- install -Dm644 /dev/stdin "${pkgdir}/usr/share/applications/${pkgname}.desktop" <<END
+ install -Dm644 /dev/stdin "${pkgdir}/usr/share/applications/Zettlr.desktop" <<END
[Desktop Entry]
Name=Zettlr
Comment=A powerful Markdown Editor with integrated tree view
-Exec=${pkgname} %U
+Exec=Zettlr %U
Terminal=false
Type=Application
-Icon=${pkgname}
+Icon=Zettlr
StartupWMClass=Zettlr
MimeType=text/markdown;
Categories=Office;
END
# generate mimetype configuration file to associate with zettlr
- install -Dm644 /dev/stdin "${pkgdir}/usr/share/mime/packages/${pkgname}.xml" <<END
+ install -Dm644 /dev/stdin "${pkgdir}/usr/share/mime/packages/Zettlr.xml" <<END
<?xml version="1.0" encoding="utf-8"?>
<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
<mime-type type="text/markdown">