summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorC.T Liu2020-08-04 11:48:56 +0000
committerC.T Liu2020-08-04 11:48:56 +0000
commit6b7b08069b2d1ee2288fc217ba153841381e2975 (patch)
treefcd573cf68d138154a66f5ed4ed915d782b36027 /PKGBUILD
parent7d551600b26741ae48f8c418d8848e8562463f07 (diff)
downloadaur-6b7b08069b2d1ee2288fc217ba153841381e2975.tar.gz
updpkg
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 57e36a83dc52..e5f0675563f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,21 @@
# Maintainer: BrLi <brli at chakralinux dot org>
pkgname=zettlr
-pkgver=1.7.1
+pkgver=1.7.4
pkgrel=1
pkgdesc="A markdown editor for writing academic texts and taking notes"
arch=('x86_64')
url='https://www.zettlr.com'
-license=('GPL')
+license=('GPL' 'custom')
depends=(electron ttf-webhostinghub-glyphs otf-crimson-text)
makedepends=(yarn git gulp)
optdepends=('pandoc: For exporting to various format'
'texlive-bin: For Latex support'
'ttf-lato: Display output in a more comfortable way')
-source=(git+https://github.com/Zettlr/Zettlr.git#tag=v"${pkgver}")
+_commit=8b08c0249bf7946ccd2809d81b8c827470f4ee86 # v1.7.4^0
+source=(git+https://github.com/Zettlr/Zettlr.git#commit="${_commit}")
sha1sums=('SKIP')
-# source=(https://github.com/Zettlr/Zettlr/archive/v${pkgver}.tar.gz)
-# sha256sums=('765c9d74a7d9a6a35df88cb6ca23db7e88409e32d0c9cbf4b234cc47d8d69b39')
-
prepare() {
cd "${srcdir}/Zettlr"
@@ -65,7 +63,7 @@ build() {
# # The "test" function in package.json
# node node_modules/mocha/bin/mocha
# # The "test-gui" function in package.json, not useful in our case
-# # node scripts/test-gui.js
+# node scripts/test-gui.js
# # Clean up
# yarn remove electron
# rm yarn.lock
@@ -91,6 +89,10 @@ END
"${pkgdir}/usr/share/icons/hicolor/${px}x${px}/apps/${pkgname}.png"
done
+ # install legal notice
+ install -Dm644 "${srcdir}/Zettlr/README.md" "${pkgdir}/usr/share/licenses/${pkgname}/README"
+ install -Dm644 "${srcdir}/Zettlr/resources/icons/README.md" "${pkgdir}/usr/share/licenses/${pkgname}/icon/README"
+
# generate freedesktop entry files
install -Dm644 /dev/stdin "${pkgdir}/usr/share/applications/${pkgname}.desktop" <<END
[Desktop Entry]