summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorC.T Liu2020-07-06 17:36:13 +0000
committerC.T Liu2020-07-06 17:36:13 +0000
commit7d551600b26741ae48f8c418d8848e8562463f07 (patch)
treed8b17abd24635988cfa7dc620b1327107522bcba /PKGBUILD
parent7f51322f35f1ad4aeb5a412ec14b8a3182c52e09 (diff)
downloadaur-7d551600b26741ae48f8c418d8848e8562463f07.tar.gz
updpkg
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 16 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e1de76af7ec3..57e36a83dc52 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: BrLi <brli at chakralinux dot org>
pkgname=zettlr
-pkgver=1.7.0
+pkgver=1.7.1
pkgrel=1
pkgdesc="A markdown editor for writing academic texts and taking notes"
arch=('x86_64')
@@ -35,8 +35,8 @@ build() {
yarn less
yarn handlebars
yarn lang:refresh
- NODE_ENV=production node node_modules/webpack/bin/webpack.js
yarn reveal:build
+ NODE_ENV=production node node_modules/webpack/bin/webpack.js --progress --colors
cd "${srcdir}/Zettlr/source"
yarn install --pure-lockfile --cache-folder "${srcdir}/cache"
@@ -58,6 +58,20 @@ build() {
find . -name "yarn.lock" -exec rm -rfv {} +
}
+# check() {
+# cd "${srcdir}/Zettlr"
+# # Require electron module to test
+# yarn add --cache-folder "${srcdir}/cache" --link-folder "${srcdir}/link" electron
+# # The "test" function in package.json
+# node node_modules/mocha/bin/mocha
+# # The "test-gui" function in package.json, not useful in our case
+# # node scripts/test-gui.js
+# # Clean up
+# yarn remove electron
+# rm yarn.lock
+# rm node_modules/.bin -rf
+# }
+
package() {
local _destdir=usr/lib/"${pkgname}"
install -dm755 "${pkgdir}/${_destdir}"