summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrLi2020-12-04 21:15:08 +0800
committerBrLi2020-12-04 21:15:08 +0800
commitff09d4b8ec406803caba8cc64f255bb91a2fb51e (patch)
treec7d54850a0a270cf8e473d602515addb301ddacb /PKGBUILD
parent8118e78f3ecc003e6d71e6aa8a2d06d9d5a731ea (diff)
downloadaur-ff09d4b8ec406803caba8cc64f255bb91a2fb51e.tar.gz
updpkg, user git commit for csl source
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 9 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9457f13f8dd8..ebeb0ef05c36 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: BrLi <brli at chakralinux dot org>
pkgname=zettlr
-pkgver=1.8.0
-pkgrel=4
+pkgver=1.8.1
+pkgrel=1
pkgdesc="A markdown editor for writing academic texts and taking notes"
arch=('x86_64')
url='https://www.zettlr.com'
@@ -13,20 +13,18 @@ optdepends=('pandoc: For exporting to various format'
'texlive-bin: For Latex support'
'ttf-lato: Display output in a more comfortable way')
options=('!strip')
-_commit=b7165b4c3e69cec8c62b7203df41fcbeb91d178d # 1.8.0^0
+_commit=93273f39a0a178f82ad3c8ed64d01faf4224aab1 # 1.8.1^0
+_csl_locale_commit=cbb45961b815594f35c36da7e78154feb5647823
_lang=('de-DE' 'en-GB' 'en-US' 'fr-FR' 'ja-JP' 'zh-CN' 'es-ES' 'ru-RU')
source=(git+https://github.com/Zettlr/Zettlr.git#commit="${_commit}"
- # Fix language files search path
- fix-lang-search-path.patch::https://github.com/Zettlr/Zettlr/pull/1466.patch
# citation style
- https://github.com/citation-style-language/locales/archive/master.zip
- https://raw.githubusercontent.com/citation-style-language/styles/master/chicago-author-date.csl
+ https://github.com/citation-style-language/locales/archive/"${_csl_locale_commit}.zip"
+ https://github.com/citation-style-language/styles/raw/master/chicago-author-date.csl
# Chinese(Taiwan) translation
https://github.com/Brli/zetter-zh-TW/raw/master/zh-TW.json)
# translations
sha256sums=('SKIP'
- '906041fbf93b1533dc14733ce5214df306f161519e55e79881ce237835b865bf'
- '4a3b89033d6bbb669a7d046d23224dc3eaaa2840cc8a5dd2c5d6201a61e3f1a1'
+ '8ee8c7e0ea63aacf811fb6f4bdb8f8f32929bf9afdad2f0ffc2f6bfb721d1fd5'
'2b7cd6c1c9be4add8c660fb9c6ca54f1b6c3c4f49d6ed9fa39c9f9b10fcca6f4'
'81730193afc64908f820020a19bfeda4475c67ada92e8567a39c9313a3d65ff0')
for _l in ${_lang[@]}; do
@@ -37,9 +35,6 @@ done
prepare() {
cd "${srcdir}/Zettlr"
- # regression introduced in e5d807a36dd9fd952449afe1aa19ad9bfec4b690
- patch -Np1 -i ${srcdir}/fix-lang-search-path.patch
-
# pandoc citeproc argument deprecation
sed 's,--filter pandoc-citeproc,--citeproc,' -i source/main/modules/export/run-pandoc.js
@@ -61,8 +56,8 @@ prepare() {
cp "${srcdir}/zh-TW.json" source/common/lang/
# csl:refresh from package.json
- cp $(find "${srcdir}/locales-master/" -name "*.xml") source/app/service-providers/assets/csl-locales/
- cp "${srcdir}/locales-master/locales.json" source/app/service-providers/assets/csl-locales/
+ cp $(find "${srcdir}/locales-${_csl_locale_commit}/" -name "*.xml") source/app/service-providers/assets/csl-locales/
+ cp "${srcdir}/locales-${_csl_locale_commit}/locales.json" source/app/service-providers/assets/csl-locales/
cp "${srcdir}/chicago-author-date.csl" source/app/service-providers/assets/csl-styles/
}