summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorskydrome2015-06-20 10:00:11 -0400
committerskydrome2015-06-20 10:00:11 -0400
commit1718c68f158fbe5517fa223e9db3cf89c46738b5 (patch)
tree231c6b619bdd167439e9a21444f349297d53f029 /PKGBUILD
parentd3a5a83afb6651fa24fb9fc51e2c058052b533c3 (diff)
downloadaur-1718c68f158fbe5517fa223e9db3cf89c46738b5.tar.gz
minor cleanup
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 55928e8e3a65..6cad78744260 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,25 @@
pkgname=zfec
pkgver=1.4.24
pkgrel=2
-pkgdesc="a fast erasure codec which can be used with the command-line, C, Python, or Haskell"
+pkgdesc="A fast erasure codec which can be used with the command-line, C, Python, or Haskell"
arch=('i686' 'x86_64')
-url='http://pypi.python.org/pypi/zfec'
+url='https://pypi.python.org/pypi/zfec'
license=('GPL')
depends=('python2' 'pyutil' 'zbase32')
-makedepends=('darcsver' 'setuptools_darcs')
-source=( http://pypi.python.org/packages/source/z/zfec/zfec-$pkgver.tar.gz )
+source=("https://pypi.python.org/packages/source/z/zfec/zfec-${pkgver}.tar.gz")
md5sums=('e1bca3a1f18374f72bdf8cd42ea9c919')
build(){
- cd "$srcdir/$pkgname-$pkgver"
- python2 setup.py build
- python2 setup.py test
+ cd "$srcdir/zfec-$pkgver"
+ python2 setup.py build
+}
+
+check() {
+ cd "$srcdir/zfec-$pkgver"
+ python2 setup.py test
}
package(){
- cd "$srcdir/$pkgname-$pkgver"
- python2 setup.py install --root="$pkgdir"
+ cd "$srcdir/zfec-$pkgver"
+ python2 setup.py install --root="$pkgdir" --optimize=1
}