summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2022-08-30 23:49:07 -0500
committerLuis Martinez2022-08-30 23:49:07 -0500
commit7c8a2f014973a193cdaa6adc5a9ecdbbf55ef619 (patch)
treef9d59684d5899294a169df4f3ce3e4953c9fca5f /PKGBUILD
parent14771d524b169bfecc1e139ee71a3610c403eb73 (diff)
downloadaur-7c8a2f014973a193cdaa6adc5a9ecdbbf55ef619.tar.gz
packaging cleanup
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 17 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ad496e2dedbf..4247c1141c12 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,32 @@
-# Maintainer: Nicolas Pouillard <nicolas.pouillard@gmail.com>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Nicolas Pouillard <nicolas.pouillard@gmail.com>
# Contributor: Peter Simons <simons@cryp.to>
pkgbase=zfec
pkgname=python-zfec
pkgver=1.5.7.2
-pkgrel=1
-pkgdesc="A fast erasure codec which can be used with the command-line, C, Python, or Haskell"
-arch=('any')
-url='https://pypi.python.org/pypi/zfec'
+pkgrel=2
+pkgdesc="Fast erasure coding tool"
+arch=('x86_64')
+url='https://github.com/tahoe-lafs/zfec'
license=('GPL')
depends=('python')
makedepends=('python-build' 'python-installer' 'python-wheel' 'python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/z/zfec/zfec-${pkgver}.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/z/zfec/zfec-$pkgver.tar.gz")
sha256sums=('4ee519be0dcc7da2e88482bcfc0bf977a425e1d7e8278cf5bbbb8d00f8a2afb6')
+prepare() {
+ cd "zfec-$pkgver"
+ # deleting SOURCES.txt and excluding tests isn't good enough
+ rm -rf zfec/test
+}
+
build() {
- cd "zfec-$pkgver"
- python -m build --wheel --no-isolation
+ cd "zfec-$pkgver"
+ python -m build --wheel --no-isolation
}
package_python-zfec() {
- cd "zfec-$pkgver"
- python -m installer --destdir="$pkgdir" dist/*.whl
+ cd "zfec-$pkgver"
+ PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir" dist/*.whl
}