summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorskydrome2022-08-29 16:20:57 -0400
committerskydrome2022-08-29 16:20:57 -0400
commita945e9a157b0cb0af9387be20775001e445fe3f2 (patch)
tree3b959937771a42693afed47a022fc889886ebe90 /PKGBUILD
parent2767a04edbc7f626fe1286a759341de4e69e0e2d (diff)
downloadaur-a945e9a157b0cb0af9387be20775001e445fe3f2.tar.gz
remove python2 package and install using a wheel
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 6 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a30983caa7f7..55c44f88cbc5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,30 +2,24 @@
# Contributor: Peter Simons <simons@cryp.to>
pkgbase=zfec
-pkgname=('python2-zfec' 'python-zfec')
+pkgname=python-zfec
pkgver=1.5.5
pkgrel=1
pkgdesc="A fast erasure codec which can be used with the command-line, C, Python, or Haskell"
arch=('any')
url='https://pypi.python.org/pypi/zfec'
license=('GPL')
-makedepends=('python2-setuptools' 'python-setuptools')
+depends=('python')
+makedepends=('python-build' 'python-installer' 'python-wheel' 'python-setuptools')
source=("https://files.pythonhosted.org/packages/source/z/zfec/zfec-${pkgver}.tar.gz")
sha256sums=('6033b2f3cc3edacf3f7eeed5f258c1ebf8a1d7e5e35b623db352512ce564e5ca')
-package_python2-zfec() {
- depends=('python2-pyutil')
- replaces=('zfec')
- conflicts=('python-zfec')
-
+build() {
cd "zfec-$pkgver"
- python2 setup.py install --root="$pkgdir" --prefix='/usr' --optimize=1
+ python -m build --wheel --no-isolation
}
package_python-zfec() {
- depends=('python-pyutil')
- conflicts=('python2-zfec')
-
cd "zfec-$pkgver"
- python setup.py install --root="$pkgdir" --prefix='/usr' --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}