summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJaroslav Lichtblau2014-11-28 20:17:14 +0100
committerJaroslav Lichtblau2014-11-28 20:17:14 +0100
commit352c604b0d29fc59093efad4fbe34747deba8743 (patch)
treea0ec6a23e6fa867c8af6a59c4b8066c37f5df7f8 /PKGBUILD
downloadaur-352c604b0d29fc59093efad4fbe34747deba8743.tar.gz
Initial PKGBUILD status as of 28.11.2014
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..780b8f7eaf02
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+
+pkgname=zfo-editor
+pkgver=0.3.2
+pkgrel=1
+pkgdesc="ZFO editor allows user to interact with ZFO forms"
+arch=('any')
+url="http://labs.nic.cz/page/768/zfo-editor/"
+license=('GPL2')
+depends=('python-lxml' 'pywebkitgtk')
+makedepends=('python2-distribute')
+source=(http://labs.nic.cz/files/labs/zfo_editor/$pkgname-$pkgver.tar.gz)
+sha256sums=('36dda2e12f790c4a84ee81844ab226e8accbe8868ddbeabe0753112656b0a2c5')
+
+build() {
+ cd ${srcdir}/$pkgname-$pkgver
+
+#Python2 fix
+ for file in $(find . -name '*.py' -print); do
+ sed -i 's_^#!.*/usr/bin/python_#!/usr/bin/python2_' $file
+ sed -i 's_^#!.*/usr/bin/env.*python_#!/usr/bin/env python2_' $file
+ done
+
+ python2 setup.py install --root=${pkgdir}
+}