summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJesus Alvarez2016-06-13 01:36:04 -0700
committerJesus Alvarez2016-06-13 01:36:04 -0700
commit016bae471837af56f3627d59b52303fb1999806a (patch)
treef2aca5e44b810ba8151972f1f26565710f860a44 /PKGBUILD
downloadaur-016bae471837af56f3627d59b52303fb1999806a.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4975d2b580e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Jesus Alvarez <jeezusjr at gmail dot com>
+#
+# This PKGBUILD was generated by the archzfs build scripts located at
+#
+# http://github.com/archzfs/archzfs
+#
+# ! WARNING !
+#
+# The archzfs packages are kernel modules, so these PKGBUILDS will only work with the kernel package they target. In this
+# case, the archzfs-archiso-linux packages will only work with the archiso ISO! To have a single PKGBUILD target many kernels
+# would make for a cluttered PKGBUILD!
+#
+# If you have a custom kernel, you will need to change things in the PKGBUILDS. If you would like to have AUR or archzfs repo
+# packages for your favorite kernel package built using the archzfs build tools, submit a request in the Issue tracker on the
+# archzfs github page.
+#
+#
+pkgname="zfs-archiso-linux"
+pkgver=0.6.5.7_4.5.4_1
+pkgrel=1
+pkgdesc="Kernel modules for the Zettabyte File System."
+depends=("kmod" "spl-archiso-linux" "zfs-utils-archiso-linux" "linux=4.5.4")
+makedepends=("linux-headers=4.5.4")
+arch=("x86_64")
+url="http://zfsonlinux.org/"
+source=("http://archive.zfsonlinux.org/downloads/zfsonlinux/zfs/zfs-0.6.5.7.tar.gz")
+sha256sums=("4a9e271bb9a6af8d564e4d5800e4fff36224f1697b923a7253659bdda80dc590")
+groups=("archzfs-archiso-linux")
+license=("CDDL")
+install=zfs.install
+provides=("zfs")
+
+build() {
+ cd "${srcdir}/zfs-0.6.5.7"
+ ./autogen.sh
+ ./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
+ --datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
+ --libexecdir=/usr/lib/zfs-0.6.5.7 --with-config=kernel \
+ --with-linux=/usr/lib/modules/4.5.4-1-ARCH/build
+ make
+}
+
+package() {
+ cd "${srcdir}/zfs-0.6.5.7"
+ make DESTDIR="${pkgdir}" install
+ cp -r "${pkgdir}"/{lib,usr}
+ rm -r "${pkgdir}"/lib
+ # Remove reference to ${srcdir}
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.5.4-1-ARCH/Module.symvers
+}