summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBin Jin2015-10-13 14:30:34 +0200
committerBin Jin2015-10-13 14:30:34 +0200
commit3232ccab23379777632c6144b52b213f954b5219 (patch)
tree05f85b4e0eeb826af792d2410e16bfa08ec6bffd /PKGBUILD
parente555f852e141418b91ea05719a5d9d9670839257 (diff)
downloadaur-3232ccab23379777632c6144b52b213f954b5219.tar.gz
update pkgver format
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 600a811142d3..cc9bdd31dfe0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgbase="zfs-dkms-git"
pkgname=("zfs-dkms-git" "zfs-utils-dkms-git")
-pkgver=0.6.5.2_0_g0b7b4bd
+pkgver=0.6.5.2_r0_g0b7b4bd
pkgrel=1
license=('CDDL')
makedepends=("git")
@@ -22,7 +22,7 @@ md5sums=('SKIP'
pkgver() {
cd "${srcdir}/zfs"
- git describe --match "zfs-*" --long --tags | sed -e 's|zfs-||g' -e 's|[-: ]|_|g'
+ git describe --match "zfs-*" --long --tags | sed -e 's|zfs-||' -e 's|-\([0-9]*-g\)|-r\1|' -e 's|[-: ]|_|g'
}
build() {
@@ -53,7 +53,7 @@ package_zfs-dkms-git() {
install -d ${pkgdir}/usr/src
cp -a ${srcdir}/zfs ${pkgdir}/usr/src/zfs-${pkgver%%_*}
cd ${pkgdir}/usr/src/zfs-${pkgver%%_*}
- rm -rf .git .gitignore
+ rm -rf .git*
make clean
}