summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorArchzfs Buildbot2019-09-21 23:09:01 +0000
committerArchzfs Buildbot2019-09-21 23:09:01 +0000
commit0c73e98f3fe3ded517f5c0bcf66bb7528df4f910 (patch)
treef90f7a7ed8f8f8d142f735d4b07ef369a9395e80 /PKGBUILD
parent98914ef9083ec8835e3eb8b2522518e028aecf63 (diff)
downloadaur-0c73e98f3fe3ded517f5c0bcf66bb7528df4f910.tar.gz
Semi-automated update for kernel 5.3.0.arch1-1 + zfs 0.8.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 18 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5965e8a697a0..1adc7a3c18b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,25 +18,37 @@
pkgbase="zfs-linux"
pkgname=("zfs-linux" "zfs-linux-headers")
_zfsver="0.8.1"
-_kernelver="5.2.14.arch2-1"
-_extramodules="5.2.14-arch2-1-ARCH"
+_kernelver="5.3.arch1-1"
+_extramodules="5.3.0-arch1-1-ARCH"
pkgver="${_zfsver}_$(echo ${_kernelver} | sed s/-/./g)"
pkgrel=1
makedepends=("linux-headers=${_kernelver}")
arch=("x86_64")
-url="http://zfsonlinux.org/"
-source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-${_zfsver}/zfs-${_zfsver}.tar.gz")
-sha256sums=("0af79fde44b7b8ecb94d5166ce2e4fff7409c20ed874c2d759db92909e6c2799")
+url="https://zfsonlinux.org/"
+source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-${_zfsver}/zfs-${_zfsver}.tar.gz"
+ "linux-5.3-compat-rw_semaphore-owner.patch"
+ "linux-5.3-compat-retire-rw_tryupgrade.patch"
+ "linux-5.3-compat-Makefile-subdir-m-no-longer-supported.patch")
+sha256sums=("0af79fde44b7b8ecb94d5166ce2e4fff7409c20ed874c2d759db92909e6c2799"
+ "c65c950abda42fb91fb99c6c916a50720a522c53e01a872f9310a4719bae9e2a"
+ "19f798a29c00874874751880f1146c5849b8ebdb6233d8ae923f9fdd4661de19"
+ "6c4627875dd1724f64a196ea584812c99635897dc31cb23641f308770289059a")
license=("CDDL")
depends=("kmod" "zfs-utils=${_zfsver}" "linux=${_kernelver}")
+prepare() {
+ cd "${srcdir}/zfs-${_zfsver}"
+ patch -Np1 -i ${srcdir}/linux-5.3-compat-rw_semaphore-owner.patch
+ patch -Np1 -i ${srcdir}/linux-5.3-compat-retire-rw_tryupgrade.patch
+ patch -Np1 -i ${srcdir}/linux-5.3-compat-Makefile-subdir-m-no-longer-supported.patch
+}
build() {
cd "${srcdir}/zfs-${_zfsver}"
./autogen.sh
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
- --libexecdir=/usr/lib/zfs-${zfsver} --with-config=kernel \
+ --libexecdir=/usr/lib/zfs-${_zfsver} --with-config=kernel \
--with-linux=/usr/lib/modules/${_extramodules}/build \
--with-linux-obj=/usr/lib/modules/${_extramodules}/build
make