summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJesus Alvarez2018-03-16 20:53:32 -0700
committerJesus Alvarez2018-03-16 20:53:32 -0700
commit7fce2c679cec05a291616a4be3822bceb4d07a6a (patch)
treeeb82e91cfbebc1b1abd6327e932a73d2b330f57d /PKGBUILD
parent075b3c1d79575028f5537c8d2914e8830883bce9 (diff)
downloadaur-7fce2c679cec05a291616a4be3822bceb4d07a6a.tar.gz
Semi-automated update for 4.15.9.1-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d3cf10b1b250..952e12b3ded5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,15 +17,15 @@
pkgbase="zfs-linux"
pkgname=("zfs-linux" "zfs-linux-headers")
-pkgver=0.7.6.4.15.8.1
+pkgver=0.7.6.4.15.9.1
pkgrel=1
-makedepends=("linux-headers=4.15.8-1" "spl-linux-headers")
+makedepends=("linux-headers=4.15.9-1" "spl-linux-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.6/zfs-0.7.6.tar.gz")
sha256sums=("1687f4041a990e35caccc4751aa736e8e55123b81d5f5a35b11916d9e580c23d")
license=("CDDL")
-depends=("kmod" "spl-linux" "zfs-utils-common=0.7.6" "linux=4.15.8-1")
+depends=("kmod" "spl-linux" "zfs-utils-common=0.7.6" "linux=4.15.9-1")
build() {
cd "${srcdir}/zfs-0.7.6"
@@ -33,8 +33,8 @@ build() {
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
--libexecdir=/usr/lib/zfs-0.7.6 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.15.8-1-ARCH/build \
- --with-linux-obj=/usr/lib/modules/4.15.8-1-ARCH/build
+ --with-linux=/usr/lib/modules/4.15.9-1-ARCH/build \
+ --with-linux-obj=/usr/lib/modules/4.15.9-1-ARCH/build
make
}
@@ -55,10 +55,10 @@ package_zfs-linux() {
package_zfs-linux-headers() {
pkgdesc="Kernel headers for the Zettabyte File System."
- conflicts=('zfs-archiso-linux-headers' 'zfs-archiso-linux-git-headers' 'zfs-linux-hardened-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-git-headers' 'zfs-linux-threadripper-headers' 'zfs-linux-threadripper-git-headers' 'zfs-linux-threadripper-vfio-headers' 'zfs-linux-threadripper-vfio-git-headers' 'zfs-linux-vfio-headers' 'zfs-linux-vfio-git-headers' 'zfs-linux-zen-headers' 'zfs-linux-zen-git-headers' )
+ conflicts=('zfs-archiso-linux-headers' 'zfs-archiso-linux-git-headers' 'zfs-linux-hardened-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-git-headers' 'zfs-linux-vfio-headers' 'zfs-linux-vfio-git-headers' 'zfs-linux-zen-headers' 'zfs-linux-zen-git-headers' )
cd "${srcdir}/zfs-0.7.6"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.15.8-1-ARCH/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.15.9-1-ARCH/Module.symvers
}