summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJesus Alvarez2017-10-20 12:42:47 -0700
committerJesus Alvarez2017-10-20 12:42:47 -0700
commitdfa1021dc838403a4d272581e4a730b3f6f7d0e8 (patch)
treec6df8a85d63513e14f305fe5cff4fb48f57d86cb /PKGBUILD
parent78b6667cdef02ee5cd7d981682dc64b296d4ab0b (diff)
downloadaur-dfa1021dc838403a4d272581e4a730b3f6f7d0e8.tar.gz
Semi-automated update for 4.13.7.1-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fad04727b787..6328956bd2c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,22 +17,22 @@
pkgbase="zfs-linux"
pkgname=("zfs-linux" "zfs-linux-headers")
-pkgver=0.7.2.4.13.7.1
+pkgver=0.7.3.4.13.7.1
pkgrel=1
makedepends=("linux-headers=4.13.7-1" "spl-linux-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
-source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.2/zfs-0.7.2.tar.gz")
-sha256sums=("f75f4d8bbb8241e3d06321b53914e53fa22d1ccc8be89819b578b46e5d3e5cf4")
+source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.3/zfs-0.7.3.tar.gz")
+sha256sums=("cb8fc606835d3f91471e49aca31a6a0a71733b1cbe74fa510e0fe0efa670fe51")
license=("CDDL")
-depends=("kmod" "spl-linux" "zfs-utils-common>=0.7.2" "linux=4.13.7-1")
+depends=("kmod" "spl-linux" "zfs-utils-common>=0.7.3" "linux=4.13.7-1")
build() {
- cd "${srcdir}/zfs-0.7.2"
+ cd "${srcdir}/zfs-0.7.3"
./autogen.sh
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
- --libexecdir=/usr/lib/zfs-0.7.2 --with-config=kernel \
+ --libexecdir=/usr/lib/zfs-0.7.3 --with-config=kernel \
--with-linux=/usr/lib/modules/4.13.7-1-ARCH/build \
--with-linux-obj=/usr/lib/modules/4.13.7-1-ARCH/build
make
@@ -45,7 +45,7 @@ package_zfs-linux() {
groups=("archzfs-linux")
conflicts=('zfs-linux-git')
replaces=("zfs-git")
- cd "${srcdir}/zfs-0.7.2"
+ cd "${srcdir}/zfs-0.7.3"
make DESTDIR="${pkgdir}" install
cp -r "${pkgdir}"/{lib,usr}
rm -r "${pkgdir}"/lib
@@ -56,7 +56,7 @@ package_zfs-linux() {
package_zfs-linux-headers() {
pkgdesc="Kernel headers for the Zettabyte File System."
conflicts=('zfs-archiso-linux-headers' 'zfs-linux-hardened-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-git-headers' 'zfs-linux-zen-headers' 'zfs-linux-zen-git-headers' )
- cd "${srcdir}/zfs-0.7.2"
+ cd "${srcdir}/zfs-0.7.3"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}