summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJesus Alvarez2017-08-01 22:13:16 -0700
committerJesus Alvarez2017-08-01 22:13:16 -0700
commit104ef480c04732393344da6a515d6294494a12d2 (patch)
tree9c385b677efa0db25389b4b7801147233daa3ac7 /PKGBUILD
parentc79508fc2f3c485c8de57f2d4dacab640994f344 (diff)
downloadaur-104ef480c04732393344da6a515d6294494a12d2.tar.gz
Semi-automated update for 4.12.4.a_1-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD52
1 files changed, 31 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 62a775b70eb1..5644efd277af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,8 @@
-# Maintainer: Jan Houben <jan@nexttrex.de>
# Maintainer: Jesus Alvarez <jeezusjr at gmail dot com>
#
# This PKGBUILD was generated by the archzfs build scripts located at
#
-# http://github.com/minextu/archzfs/tree/linux-hardened
+# http://github.com/archzfs/archzfs
#
# ! WARNING !
#
@@ -16,38 +15,49 @@
# archzfs github page.
#
#
-pkgname="zfs-linux-hardened"
-pkgver=0.6.5.11_4.12.e.0_1
-pkgrel=1
-pkgdesc="Kernel modules for the Zettabyte File System."
-depends=("kmod" "spl-linux-hardened" "zfs-utils-linux-hardened" "linux-hardened=4.12.e-1")
-makedepends=("linux-hardened-headers=4.12.e-1")
+pkgbase="zfs-linux-hardened"
+pkgname=("zfs-linux-hardened" "zfs-linux-hardened-headers")
+pkgver=0.7.0_4.12.4.a_1
+pkgrel=2
+makedepends=("linux-hardened-headers=4.12.4.a-1" "spl-linux-hardened-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
-source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.6.5.11/zfs-0.6.5.11.tar.gz")
-sha256sums=("136b3061737f1a43f5310919cacbf1b8a0db72b792ef8b1606417aff16dab59d")
-groups=("archzfs-linux-hardened")
+source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.0/zfs-0.7.0.tar.gz")
+sha256sums=("6907524f5ca4149b799fe65cd31b552b0ae90dba5dc20524e1a24fc708d807d2")
license=("CDDL")
-install=zfs.install
-provides=("zfs")
-conflicts=('zfs-linux' 'zfs-linux-git' 'zfs-linux-lts' 'zfs-linux-lts-git' 'zfs-linux-hardened-git')
+depends=("kmod" "spl-linux-hardened" "zfs-utils-common>=0.7.0" "linux-hardened=4.12.4.a-1")
build() {
- cd "${srcdir}/zfs-0.6.5.11"
+ cd "${srcdir}/zfs-0.7.0"
./autogen.sh
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
- --libexecdir=/usr/lib/zfs-0.6.5.11 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.12.0-1-hardened/build \
- --with-linux-obj=/usr/lib/modules/4.12.0-1-hardened/build
+ --libexecdir=/usr/lib/zfs-0.7.0 --with-config=kernel \
+ --with-linux=/usr/lib/modules/4.12.4-1-hardened/build \
+ --with-linux-obj=/usr/lib/modules/4.12.4-1-hardened/build
make
}
-package() {
- cd "${srcdir}/zfs-0.6.5.11"
+package_zfs-linux-hardened() {
+ pkgdesc="Kernel modules for the Zettabyte File System."
+ install=zfs.install
+ provides=("zfs")
+ groups=("archzfs-linux-hardened")
+ conflicts=('zfs-linux-hardened-git')
+ cd "${srcdir}/zfs-0.7.0"
make DESTDIR="${pkgdir}" install
cp -r "${pkgdir}"/{lib,usr}
rm -r "${pkgdir}"/lib
+ # Remove src dir
+ rm -r "${pkgdir}"/usr/src
+}
+
+package_zfs-linux-hardened-headers() {
+ pkgdesc="Kernel headers for the Zettabyte File System."
+ conflicts=('zfs-archiso-linux-headers' 'zfs-utils-common-git-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-headers' 'zfs-linux-git-headers' )
+ cd "${srcdir}/zfs-0.7.0"
+ make DESTDIR="${pkgdir}" install
+ rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.12.0-1-hardened/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.12.4-1-hardened/Module.symvers
}