summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJesus Alvarez2017-08-13 16:27:11 -0700
committerJesus Alvarez2017-08-13 16:27:11 -0700
commit19048c61db37c7624941d6fac13a79c20b4ad965 (patch)
tree2eac6f9d16aafa7b214a690dd408279abcf871c4 /PKGBUILD
parent6126ec21c6e380fbbb832cb65567be433bdd4888 (diff)
downloadaur-19048c61db37c7624941d6fac13a79c20b4ad965.tar.gz
Semi-automated update for 4.12.7.a.1-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9afb7324d1a4..593e4c3472da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,15 +17,15 @@
#
pkgbase="zfs-linux-hardened"
pkgname=("zfs-linux-hardened" "zfs-linux-hardened-headers")
-pkgver=0.7.1_4.12.5.a_1
+pkgver=0.7.1_4.12.7.a.1
pkgrel=1
-makedepends=("linux-hardened-headers=4.12.5.a-1" "spl-linux-hardened-headers")
+makedepends=("linux-hardened-headers=4.12.7.a-1" "spl-linux-hardened-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.1/zfs-0.7.1.tar.gz")
sha256sums=("231b104979ddacfeb1889e1dec175337276e7b3b109d40656089744b5caf3ef6")
license=("CDDL")
-depends=("kmod" "spl-linux-hardened" "zfs-utils-common>=0.7.1" "linux-hardened=4.12.5.a-1")
+depends=("kmod" "spl-linux-hardened" "zfs-utils-common>=0.7.1" "linux-hardened=4.12.7.a-1")
build() {
cd "${srcdir}/zfs-0.7.1"
@@ -33,8 +33,8 @@ build() {
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
--libexecdir=/usr/lib/zfs-0.7.1 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.12.5-1-hardened/build \
- --with-linux-obj=/usr/lib/modules/4.12.5-1-hardened/build
+ --with-linux=/usr/lib/modules/4.12.7-1-hardened/build \
+ --with-linux-obj=/usr/lib/modules/4.12.7-1-hardened/build
make
}
@@ -54,10 +54,10 @@ package_zfs-linux-hardened() {
package_zfs-linux-hardened-headers() {
pkgdesc="Kernel headers for the Zettabyte File System."
- conflicts=('zfs-archiso-linux-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-headers' 'zfs-linux-git-headers' )
+ conflicts=('zfs-archiso-linux-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-headers' 'zfs-linux-git-headers' 'zfs-linux-zen-headers' 'zfs-linux-zen-git-headers' )
cd "${srcdir}/zfs-0.7.1"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.12.5-1-hardened/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.12.7-1-hardened/Module.symvers
}