summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJesus Alvarez2017-12-26 09:52:45 -0800
committerJesus Alvarez2017-12-26 09:52:45 -0800
commit9066e082f600dab2620c76c281d1b53a26c60e9d (patch)
tree8d9d05d33243df93e96bf3d1ec1db5051b4571e0 /PKGBUILD
parent69ac7e18087b74862d3583be062ea69f4c9f0a87 (diff)
downloadaur-9066e082f600dab2620c76c281d1b53a26c60e9d.tar.gz
Semi-automated update for 4.14.9.a.1-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 31c2a67af63e..6060b805cc60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,15 +18,15 @@
pkgbase="zfs-linux-hardened"
pkgname=("zfs-linux-hardened" "zfs-linux-hardened-headers")
-pkgver=0.7.5_4.14.8.b.1
+pkgver=0.7.5_4.14.9.a.1
pkgrel=1
-makedepends=("linux-hardened-headers=4.14.8.b-1" "spl-linux-hardened-headers")
+makedepends=("linux-hardened-headers=4.14.9.a-1" "spl-linux-hardened-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.5/zfs-0.7.5.tar.gz")
-sha256sums=("SKIP")
+sha256sums=("1b826407418423379ff898c0e6ee0ada59c70754e6085a7663028330d0d8a44a")
license=("CDDL")
-depends=("kmod" "spl-linux-hardened" "zfs-utils-common=0.7.5" "linux-hardened=4.14.8.b-1")
+depends=("kmod" "spl-linux-hardened" "zfs-utils-common=0.7.5" "linux-hardened=4.14.9.a-1")
build() {
cd "${srcdir}/zfs-0.7.5"
@@ -34,8 +34,8 @@ build() {
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
--libexecdir=/usr/lib/zfs-0.7.5 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.14.8-1-hardened/build \
- --with-linux-obj=/usr/lib/modules/4.14.8-1-hardened/build
+ --with-linux=/usr/lib/modules/4.14.9-1-hardened/build \
+ --with-linux-obj=/usr/lib/modules/4.14.9-1-hardened/build
make
}
@@ -55,10 +55,10 @@ package_zfs-linux-hardened() {
package_zfs-linux-hardened-headers() {
pkgdesc="Kernel headers for the Zettabyte File System."
- conflicts=('zfs-archiso-linux-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-headers' 'zfs-linux-git-headers' 'zfs-linux-vfio-headers' 'zfs-linux-vfio-git-headers' 'zfs-linux-zen-headers' 'zfs-linux-zen-git-headers' )
+ conflicts=('zfs-archiso-linux-headers' 'zfs-archiso-linux-git-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-headers' 'zfs-linux-git-headers' 'zfs-linux-vfio-headers' 'zfs-linux-vfio-git-headers' 'zfs-linux-zen-headers' 'zfs-linux-zen-git-headers' )
cd "${srcdir}/zfs-0.7.5"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.14.8-1-hardened/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.14.9-1-hardened/Module.symvers
}