summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJesus Alvarez2018-05-11 15:48:42 -0700
committerJesus Alvarez2018-05-11 15:48:42 -0700
commit9cc99045772cd763f257f1fa949574f0449e5d04 (patch)
tree2a0ac0b76ae2e7f3d2db19ffb37d82aefe568d98 /PKGBUILD
parent684d9b48810a7990e55f97f25c594f3351b283cb (diff)
downloadaur-9cc99045772cd763f257f1fa949574f0449e5d04.tar.gz
Semi-automated update for 4.16.8.a.1-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 13 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5246c18ead18..adf09e32531b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,24 +18,24 @@
pkgbase="zfs-linux-hardened"
pkgname=("zfs-linux-hardened" "zfs-linux-hardened-headers")
-pkgver=0.7.8_4.16.7.a.1
-pkgrel=2
-makedepends=("linux-hardened-headers=4.16.7.a-1" "spl-linux-hardened-headers")
+pkgver=0.7.9_4.16.8.a.1
+pkgrel=1
+makedepends=("linux-hardened-headers=4.16.8.a-1" "spl-linux-hardened-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
-source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.8/zfs-0.7.8.tar.gz")
-sha256sums=("70ba0edd72914d4bfc9a9426cf26725e955a9509acbddb6902efb9eebb35f150")
+source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.9/zfs-0.7.9.tar.gz")
+sha256sums=("f50ca2441c6abde4fe6b9f54d5583a45813031d6bb72b0011b00fc2683cd9f7a")
license=("CDDL")
-depends=("kmod" "spl-linux-hardened" "zfs-utils-common=0.7.8" "linux-hardened=4.16.7.a-1")
+depends=("kmod" "spl-linux-hardened" "zfs-utils-common=0.7.9" "linux-hardened=4.16.8.a-1")
build() {
- cd "${srcdir}/zfs-0.7.8"
+ cd "${srcdir}/zfs-0.7.9"
./autogen.sh
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
- --libexecdir=/usr/lib/zfs-0.7.8 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.16.7-1-hardened/build \
- --with-linux-obj=/usr/lib/modules/4.16.7-1-hardened/build
+ --libexecdir=/usr/lib/zfs-0.7.9 --with-config=kernel \
+ --with-linux=/usr/lib/modules/4.16.8-1-hardened/build \
+ --with-linux-obj=/usr/lib/modules/4.16.8-1-hardened/build
make
}
@@ -45,7 +45,7 @@ package_zfs-linux-hardened() {
provides=("zfs")
groups=("archzfs-linux-hardened")
conflicts=('zfs-linux-hardened-git')
- cd "${srcdir}/zfs-0.7.8"
+ cd "${srcdir}/zfs-0.7.9"
make DESTDIR="${pkgdir}" install
cp -r "${pkgdir}"/{lib,usr}
rm -r "${pkgdir}"/lib
@@ -56,9 +56,9 @@ package_zfs-linux-hardened() {
package_zfs-linux-hardened-headers() {
pkgdesc="Kernel headers for the Zettabyte File System."
conflicts=('zfs-archiso-linux-headers' 'zfs-archiso-linux-git-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-headers' 'zfs-linux-git-headers' 'zfs-linux-vfio-headers' 'zfs-linux-vfio-git-headers' 'zfs-linux-zen-headers' 'zfs-linux-zen-git-headers' )
- cd "${srcdir}/zfs-0.7.8"
+ cd "${srcdir}/zfs-0.7.9"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.16.7-1-hardened/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.16.8-1-hardened/Module.symvers
}