summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJesus Alvarez2018-03-20 14:37:16 -0700
committerJesus Alvarez2018-03-20 14:37:16 -0700
commitfb8bbe58b2094bf250d6d2d8dccc796ade0e82a9 (patch)
tree9fbf57a9036df937af0b3d951297640bfd77753a /PKGBUILD
parentb422e2568c87ed1e26825bd9bedfa600804ec75c (diff)
downloadaur-fb8bbe58b2094bf250d6d2d8dccc796ade0e82a9.tar.gz
Semi-automated update for 4.15.10.a.1-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 389cbbb18793..de7b3d531225 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,22 +18,22 @@
pkgbase="zfs-linux-hardened"
pkgname=("zfs-linux-hardened" "zfs-linux-hardened-headers")
-pkgver=0.7.6_4.15.10.a.1
+pkgver=0.7.7_4.15.10.a.1
pkgrel=1
makedepends=("linux-hardened-headers=4.15.10.a-1" "spl-linux-hardened-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
-source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.6/zfs-0.7.6.tar.gz")
-sha256sums=("1687f4041a990e35caccc4751aa736e8e55123b81d5f5a35b11916d9e580c23d")
+source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.7/zfs-0.7.7.tar.gz")
+sha256sums=("db8ca69dc1d257175421a86bc81c861b2b24cc48db0832c954d9553fe50d0bb9")
license=("CDDL")
-depends=("kmod" "spl-linux-hardened" "zfs-utils-common=0.7.6" "linux-hardened=4.15.10.a-1")
+depends=("kmod" "spl-linux-hardened" "zfs-utils-common=0.7.7" "linux-hardened=4.15.10.a-1")
build() {
- cd "${srcdir}/zfs-0.7.6"
+ cd "${srcdir}/zfs-0.7.7"
./autogen.sh
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
- --libexecdir=/usr/lib/zfs-0.7.6 --with-config=kernel \
+ --libexecdir=/usr/lib/zfs-0.7.7 --with-config=kernel \
--with-linux=/usr/lib/modules/4.15.10-1-hardened/build \
--with-linux-obj=/usr/lib/modules/4.15.10-1-hardened/build
make
@@ -45,7 +45,7 @@ package_zfs-linux-hardened() {
provides=("zfs")
groups=("archzfs-linux-hardened")
conflicts=('zfs-linux-hardened-git')
- cd "${srcdir}/zfs-0.7.6"
+ cd "${srcdir}/zfs-0.7.7"
make DESTDIR="${pkgdir}" install
cp -r "${pkgdir}"/{lib,usr}
rm -r "${pkgdir}"/lib
@@ -56,7 +56,7 @@ package_zfs-linux-hardened() {
package_zfs-linux-hardened-headers() {
pkgdesc="Kernel headers for the Zettabyte File System."
conflicts=('zfs-archiso-linux-headers' 'zfs-archiso-linux-git-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-headers' 'zfs-linux-git-headers' 'zfs-linux-vfio-headers' 'zfs-linux-vfio-git-headers' 'zfs-linux-zen-headers' 'zfs-linux-zen-git-headers' )
- cd "${srcdir}/zfs-0.7.6"
+ cd "${srcdir}/zfs-0.7.7"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}