summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorArchzfs Buildbot2019-09-21 23:09:20 +0000
committerArchzfs Buildbot2019-09-21 23:09:20 +0000
commit77ff70c14760e9971961890b95c961875699b477 (patch)
tree0615cacf66131e853d2fe0dcaddef3723afeebfa /PKGBUILD
parent01afd559349fe684aba48db1674bd5981e44f433 (diff)
downloadaur-77ff70c14760e9971961890b95c961875699b477.tar.gz
Semi-automated update for kernel 5.2.15.a-1 + latest git commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 14 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d7ffc39380a9..6c92597adb16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,18 +17,24 @@
#
pkgbase="zfs-linux-hardened-git"
pkgname=("zfs-linux-hardened-git" "zfs-linux-hardened-git-headers")
-_commit='7238cbd4d3ee7eadb3131c890d0692a49ea844af'
-_zfsver="2019.09.12.r5403.g7238cbd4d"
-_kernelver="5.2.14.a-1"
-_extramodules="5.2.14.a-1-hardened"
+_commit='afc8f0a6ffb4dd2dd5e17abc39e035eb7c7bcdc8'
+_zfsver="2019.09.18.r5411.gafc8f0a6f"
+_kernelver="5.2.15.a-1"
+_extramodules="5.2.15.a-1-hardened"
pkgver="${_zfsver}_$(echo ${_kernelver} | sed s/-/./g)"
pkgrel=1
makedepends=("linux-hardened-headers=${_kernelver}" "git")
arch=("x86_64")
-url="http://zfsonlinux.org/"
-source=("git+https://github.com/zfsonlinux/zfs.git#commit=${_commit}")
-sha256sums=("SKIP")
+url="https://zfsonlinux.org/"
+source=("git+https://github.com/zfsonlinux/zfs.git#commit=${_commit}"
+ "linux-5.3-compat-rw_semaphore-owner.patch"
+ "linux-5.3-compat-retire-rw_tryupgrade.patch"
+ "linux-5.3-compat-Makefile-subdir-m-no-longer-supported.patch")
+sha256sums=("SKIP"
+ "c65c950abda42fb91fb99c6c916a50720a522c53e01a872f9310a4719bae9e2a"
+ "19f798a29c00874874751880f1146c5849b8ebdb6233d8ae923f9fdd4661de19"
+ "6c4627875dd1724f64a196ea584812c99635897dc31cb23641f308770289059a")
license=("CDDL")
depends=("kmod" "zfs-utils-git=${_zfsver}" "linux-hardened=${_kernelver}")
@@ -37,7 +43,7 @@ build() {
./autogen.sh
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
- --libexecdir=/usr/lib/zfs-${zfsver} --with-config=kernel \
+ --libexecdir=/usr/lib/zfs-${_zfsver} --with-config=kernel \
--with-linux=/usr/lib/modules/${_extramodules}/build \
--with-linux-obj=/usr/lib/modules/${_extramodules}/build
make