summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJesus Alvarez2017-08-09 22:07:42 -0700
committerJesus Alvarez2017-08-09 22:07:42 -0700
commitda7c57e22deac672572b5d1fab87f27f967eb276 (patch)
tree95efaabcb0f40fb5dd3a2faa9af1e937eab72b71 /PKGBUILD
parentb4963e0dc461eedb84ddfb7f365f7b4ccf722b9b (diff)
downloadaur-da7c57e22deac672572b5d1fab87f27f967eb276.tar.gz
Semi-automated update for 4.12.5.a_1-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5f127d08361f..c1c6f82f801d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,24 +17,24 @@
#
pkgbase="zfs-linux-hardened-git"
pkgname=("zfs-linux-hardened-git" "zfs-linux-hardened-git-headers")
-pkgver=0.7.0_r8_gaf0f84288_4.12.4.a_1
-pkgrel=2
-makedepends=("linux-hardened-headers=4.12.4.a-1" "git" "spl-linux-hardened-git-headers")
+pkgver=0.7.0_r19_g46364cb2f_4.12.5.a_1
+pkgrel=1
+makedepends=("linux-hardened-headers=4.12.5.a-1" "git" "spl-linux-hardened-git-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
source=("git+https://github.com/zfsonlinux/zfs.git")
sha256sums=("SKIP")
license=("CDDL")
-depends=("kmod" "spl-linux-hardened-git" "zfs-utils-common-git>=0.7.0_r8_gaf0f84288" "linux-hardened=4.12.4.a-1")
+depends=("kmod" "spl-linux-hardened-git" "zfs-utils-common-git>=0.7.0_r19_g46364cb2f" "linux-hardened=4.12.5.a-1")
build() {
cd "${srcdir}/zfs"
./autogen.sh
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
- --libexecdir=/usr/lib/zfs-0.7.0 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.12.4-1-hardened/build \
- --with-linux-obj=/usr/lib/modules/4.12.4-1-hardened/build
+ --libexecdir=/usr/lib/zfs-0.7.1 --with-config=kernel \
+ --with-linux=/usr/lib/modules/4.12.5-1-hardened/build \
+ --with-linux-obj=/usr/lib/modules/4.12.5-1-hardened/build
make
}
@@ -54,10 +54,10 @@ package_zfs-linux-hardened-git() {
package_zfs-linux-hardened-git-headers() {
pkgdesc="Kernel headers for the Zettabyte File System."
- conflicts=('zfs-archiso-linux-headers' 'zfs-utils-common-git-headers' 'zfs-linux-hardened-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-headers' 'zfs-linux-git-headers' )
+ conflicts=('zfs-archiso-linux-headers' 'zfs-linux-hardened-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-headers' 'zfs-linux-git-headers' )
cd "${srcdir}/zfs"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.12.4-1-hardened/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.12.5-1-hardened/Module.symvers
}