summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJesus Alvarez2017-08-13 16:25:10 -0700
committerJesus Alvarez2017-08-13 16:25:10 -0700
commita2120d0d1745614b5f2483ff650de1df1f22f3a2 (patch)
tree816ec8e5965e521b9268ce5e494143c5cb71bf7c /PKGBUILD
parentcfb5ab7c602284ccf309de00e2af5007e99dfda0 (diff)
downloadaur-a2120d0d1745614b5f2483ff650de1df1f22f3a2.tar.gz
Semi-automated update for 4.9.42.1-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3941f6e4184a..288ce3bca523 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,15 +17,15 @@
#
pkgbase="zfs-linux-lts"
pkgname=("zfs-linux-lts" "zfs-linux-lts-headers")
-pkgver=0.7.1_4.9.41_1
+pkgver=0.7.1_4.9.42.1
pkgrel=1
-makedepends=("linux-lts-headers=4.9.41" "libelf" "spl-linux-lts-headers")
+makedepends=("linux-lts-headers=4.9.42" "libelf" "spl-linux-lts-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.1/zfs-0.7.1.tar.gz")
sha256sums=("231b104979ddacfeb1889e1dec175337276e7b3b109d40656089744b5caf3ef6")
license=("CDDL")
-depends=("kmod" "spl-linux-lts" "zfs-utils-common>=0.7.1" "linux-lts=4.9.41")
+depends=("kmod" "spl-linux-lts" "zfs-utils-common>=0.7.1" "linux-lts=4.9.42")
build() {
cd "${srcdir}/zfs-0.7.1"
@@ -33,8 +33,8 @@ build() {
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
--libexecdir=/usr/lib/zfs-0.7.1 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.9.41-1-lts/build \
- --with-linux-obj=/usr/lib/modules/4.9.41-1-lts/build
+ --with-linux=/usr/lib/modules/4.9.42-1-lts/build \
+ --with-linux-obj=/usr/lib/modules/4.9.42-1-lts/build
make
}
@@ -54,10 +54,10 @@ package_zfs-linux-lts() {
package_zfs-linux-lts-headers() {
pkgdesc="Kernel headers for the Zettabyte File System."
- conflicts=('zfs-archiso-linux-headers' 'zfs-linux-hardened-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-headers' 'zfs-linux-git-headers' )
+ conflicts=('zfs-archiso-linux-headers' 'zfs-linux-hardened-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-headers' 'zfs-linux-git-headers' 'zfs-linux-zen-headers' 'zfs-linux-zen-git-headers' )
cd "${srcdir}/zfs-0.7.1"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.9.41-1-lts/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.9.42-1-lts/Module.symvers
}