summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJesus Alvarez2018-03-06 21:45:12 -0800
committerJesus Alvarez2018-03-06 21:45:12 -0800
commit9f2f700dfddb58c6986338eea9685c2ab50df3bc (patch)
treea3fb2710b7855137898eea9c921e187266482a92 /PKGBUILD
parent4a52f4936fb86f73fe6be39c6f28868df6d53dcd (diff)
downloadaur-9f2f700dfddb58c6986338eea9685c2ab50df3bc.tar.gz
Semi-automated update for 4.15.7.1-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 67301b27f130..ab6590ded743 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,15 +17,15 @@
pkgbase="zfs-linux-zen"
pkgname=("zfs-linux-zen" "zfs-linux-zen-headers")
-pkgver=0.7.6.4.15.6.1
+pkgver=0.7.6.4.15.7.1
pkgrel=1
-makedepends=("linux-zen-headers=4.15.6-1" "spl-linux-zen-headers")
+makedepends=("linux-zen-headers=4.15.7-1" "spl-linux-zen-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.6/zfs-0.7.6.tar.gz")
sha256sums=("1687f4041a990e35caccc4751aa736e8e55123b81d5f5a35b11916d9e580c23d")
license=("CDDL")
-depends=("kmod" "spl-linux-zen" "zfs-utils-common=0.7.6" "linux-zen=4.15.6-1")
+depends=("kmod" "spl-linux-zen" "zfs-utils-common=0.7.6" "linux-zen=4.15.7-1")
build() {
cd "${srcdir}/zfs-0.7.6"
@@ -33,8 +33,8 @@ build() {
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
--libexecdir=/usr/lib/zfs-0.7.6 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.15.6-1-zen/build \
- --with-linux-obj=/usr/lib/modules/4.15.6-1-zen/build
+ --with-linux=/usr/lib/modules/4.15.7-1-zen/build \
+ --with-linux-obj=/usr/lib/modules/4.15.7-1-zen/build
make
}
@@ -55,10 +55,10 @@ package_zfs-linux-zen() {
package_zfs-linux-zen-headers() {
pkgdesc="Kernel headers for the Zettabyte File System."
- conflicts=('zfs-archiso-linux-headers' 'zfs-archiso-linux-git-headers' 'zfs-linux-hardened-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-headers' 'zfs-linux-git-headers' 'zfs-linux-vfio-headers' 'zfs-linux-vfio-git-headers' 'zfs-linux-zen-git-headers' )
+ conflicts=('zfs-archiso-linux-headers' 'zfs-archiso-linux-git-headers' 'zfs-linux-hardened-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-headers' 'zfs-linux-git-headers' 'zfs-linux-threadripper-headers' 'zfs-linux-threadripper-git-headers' 'zfs-linux-vfio-headers' 'zfs-linux-vfio-git-headers' 'zfs-linux-zen-git-headers' )
cd "${srcdir}/zfs-0.7.6"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.15.6-1-zen/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.15.7-1-zen/Module.symvers
}