summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJulien Nicoulaud2019-07-02 20:21:36 +0200
committerJulien Nicoulaud2019-07-02 20:21:36 +0200
commit58837975a9a7204ba3c8651602ce4b55f9d988a0 (patch)
tree4ddb8a4f886e5dda62f3eb6fd18bb8c74f3c6b91 /PKGBUILD
downloadaur-58837975a9a7204ba3c8651602ce4b55f9d988a0.tar.gz
1.0.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ed45dc605cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Julien Nicoulaud <julien DOT nicoulaud AT gmail DOT com>
+
+pkgname=zfs-prune-snapshots
+pkgver=1.0.1
+pkgrel=1
+pkgdesc='Remove snapshots from one or more zpools that match given criteria.'
+arch=(any)
+url='https://github.com/bahamas10/zfs-prune-snapshots'
+license=(MIT)
+makedepends=(make)
+checkdepends=(shellcheck)
+depends=(bash)
+conflicts=(${pkgname}-git)
+source=("https://github.com/bahamas10/${pkgname}/archive/v${pkgver}.tar.gz")
+sha512sums=('657b5c187b4097b03c99fd6d31c358ded1181cc580690356ea06f591d72ea0734ac863598c95d18d08bf2f433d6644853e289cf0dab6a0a7209c8aa89cc68063')
+
+check() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make check
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make install DESTDIR="${pkgdir}" PREFIX=/usr
+}