summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgardar2023-10-22 03:37:05 +0000
committergardar2023-10-22 03:37:05 +0000
commit9559add8ade709711499e397314eab37d1b51343 (patch)
treec5767a0185190a08ba69bb4d0fc43e4c73c5a536 /PKGBUILD
parent2988d1ca452cd086d5a4ee79cbaec4add57185bd (diff)
downloadaur-9559add8ade709711499e397314eab37d1b51343.tar.gz
Including linuxx64.efi.stub for Arch compatibility with the latest zfsbootmenu.
Signed-off-by: gardar <gardar@users.noreply.github.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 19 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b620347c33eb..c8d40cc5e191 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,33 @@
# Contributor: gardar <aur@gardar.net>
pkgname=zfsbootmenu
pkgver=2.2.1
-pkgrel=1
+pkgrel=2
pkgdesc="ZFS bootloader for root-on-ZFS systems"
license=('MIT')
url="https://github.com/zbm-dev/$pkgname"
arch=('x86_64')
depends=('zfs' 'kexec-tools' 'fzf' 'bash' 'mbuffer' 'ncurses' 'perl-sort-versions' 'perl-boolean' 'perl-yaml-pp' 'openssl-1.1')
optdepends=('dracut' 'mkinitcpio' 'efibootmgr' 'refind' 'syslinux' 'grub')
-source=("${pkgname}-v${pkgver}.tar.gz::${url}/archive/v$pkgver.tar.gz")
-sha256sums=('02b7e8b5573c843042c9f4164209e012790c05665c463f547bed03eb0821e348')
+source=(
+ "${pkgname}-v${pkgver}.tar.gz::${url}/archive/v$pkgver.tar.gz"
+ "makefile.patch"
+ "config.yaml.patch"
+)
+sha256sums=(
+ '02b7e8b5573c843042c9f4164209e012790c05665c463f547bed03eb0821e348'
+ '5104b54d161077afed8006645762aa9661c5ae8e77c0a699a0530bfd8b750a7e'
+ 'a2fc30c06e360d39d620b9339c79299c16b0553bc2dc875c8ebd7783d9791a16'
+)
backup=("etc/${pkgname}/config.yaml" "etc/${pkgname}/mkinitcpio.conf" "etc/${pkgname}/dracut.conf.d/omit-drivers.conf" "etc/${pkgname}/dracut.conf.d/${pkgname}.conf")
+# Patch for Arch compatibility with the latest zfsbootmenu.
+# https://github.com/zbm-dev/zfsbootmenu/discussions/501
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -p1 < "${srcdir}/makefile.patch"
+ patch -p1 < "${srcdir}/config.yaml.patch"
+}
+
package() {
cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir"