summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgardar2024-06-04 13:51:31 +0000
committergardar2024-06-04 13:51:31 +0000
commit2771b0b946342360df134cffaf5fdb895826826c (patch)
treec776b76f81cfc509ae3097b4826d9f6ca275ef3d /PKGBUILD
parent3c15b12340ea71c6551d2662260924755332bed1 (diff)
downloadaur-2771b0b946342360df134cffaf5fdb895826826c.tar.gz
refactor: avoid using extra tools to parse lsblk
Signed-off-by: gardar <gardar@users.noreply.github.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 06532baff6cb..a7ba409f2a2a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,7 +17,7 @@ sha512sums=('15c7935f1733da12b99996ad10e34635bb141f459487c1cdafd38ce625bc91e75dd
'41e852c08f5e74668c3a4a839fc48f02b16dcc5446d51b1c64e95e2a1001bd0bd29ece736ea5777ea5f2d2de117dc14d00ebf4fc24e584f8b9d21c346172e82e')
package() {
- efimounts=$(lsblk -rno parttypename,mountpoint | awk -e '/EFI\\x20\(FAT-12\/16\/32\)|EFI\\x20System/ {print $2}' | tr -s '\n')
+ efimounts=$(lsblk -lno mountpoint --filter 'PARTTYPENAME=="EFI System"')
if [ -z "${efimounts-}" ]; then
echo "No ESP found, you must have a EFI partition mounted. Exiting...."