summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKaizhao Zhang2020-09-20 16:26:52 +0800
committerKaizhao Zhang2020-09-20 16:26:52 +0800
commit5811626d3bb4cfad3800ce1e0cd9eb64b0a6cc55 (patch)
tree60776c1eae2680010fe3260b65cbadd93ca49521 /PKGBUILD
downloadaur-5811626d3bb4cfad3800ce1e0cd9eb64b0a6cc55.tar.gz
Initial import from zig-dev-static
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f14ad4205908
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Kaizhao Zhang <zhangkaizhao@gmail.com>
+
+_buildver=0.6.0+58ee5f4e6
+
+pkgname=zig-dev-bin
+pkgver=20200920
+pkgrel=1
+pkgdesc="A general-purpose programming language and toolchain for maintaining robust, optimal, and reusable software"
+arch=('x86_64')
+url="https://ziglang.org/"
+license=('MIT')
+provides=('zig')
+conflicts=('zig')
+source=(
+ "https://ziglang.org/builds/zig-linux-x86_64-${_buildver}.tar.xz"
+)
+sha256sums=(
+ 'd281cccd1d850355820b7d20dfa20c3317e0f75a57561c89e8046596a1dd153f'
+)
+
+package() {
+ cd "${srcdir}/zig-linux-x86_64-${_buildver}"
+ install -D -m755 zig "${pkgdir}/usr/bin/zig"
+ cp -R lib "${pkgdir}/usr"
+ install -D -m644 langref.html "${pkgdir}/usr/share/doc/zig/langref.html"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/zig/LICENSE"
+}