summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTechcable2022-08-21 20:38:06 -0700
committerTechcable2022-08-21 20:42:42 -0700
commit9e02c353089ebce6dfb3734b78b90ef544956935 (patch)
treee9d7f865803a720b2f3db90784cc41b93ad752ab /PKGBUILD
parent3b8d78cc12b99ea597c4d5d9760a3a8abd7ca5b7 (diff)
downloadaur-9e02c353089ebce6dfb3734b78b90ef544956935.tar.gz
Revert "Handle moved docs directory"
Apparently zig moved back to the old format? Need to bump version in PKGBUILD (despite auto-update feature), so that AUR registers the change in this script. This reverts commit 3b8d78cc12b99ea597c4d5d9760a3a8abd7ca5b7.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 3 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8044c7f54bf6..b2fcc2ea8aaf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ pkgname=zig-dev-bin
# "newer" greater than the new version scheme
epoch=1
# NOTE: Hyphen -> underscore
-pkgver=0.10.0_dev.3475+b3d463c9e
+pkgver=0.10.0_dev.3659+e5e6eb983
pkgrel=1
pkgdesc="A general-purpose programming language and toolchain for maintaining robust, optimal, and reusable software"
arch=('x86_64' 'aarch64')
@@ -75,27 +75,7 @@ package() {
cp -R lib "${pkgdir}/usr/lib/zig/lib"
install -D -m755 zig "${pkgdir}/usr/lib/zig/zig"
ln -s /usr/lib/zig/zig "${pkgdir}/usr/bin/zig"
- # Old versions had a `docs` dir in the root dir
- local langref_docs="${pkgdir}/usr/share/doc/zig/langref.html";
- if [[ -d "docs" ]]; then
- install -D -m644 docs/zig/langref.html "$langref_docs";
- cp -R docs/std "${pkgdir}/usr/share/doc/zig/";
- elif [[ -f "langref.html" ]]; then
- # New versions have langref in the root dir,
- # stdlib docs in lib/zig/docs
- #
- # The first install command implicitly creates
- # the doc directory needed by stdlib :(
- #
- # NOTE: Currently missing data.js file
- #
- # https://ziglang.org/documentation/master/std/data.js
- # TODO: Maybe just download it seperately from the tarball?
- install -D -m644 langref.html "$langref_docs";
- cp -R lib/zig/docs "${pkgdir}/usr/share/doc/zig/std";
- else
- echo "Unable to find docs!" >&2;
- exit 1;
- fi;
+ install -D -m644 docs/langref.html "${pkgdir}/usr/share/doc/zig/langref.html"
+ cp -R docs/std "${pkgdir}/usr/share/doc/zig/"
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/zig/LICENSE"
}