summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRobert Manner2022-04-19 23:39:59 +0200
committerHenry Nelson2022-04-22 20:32:27 -0400
commitc20633c1a3c685ae419bd5b9b5ff778019f0744d (patch)
tree8f78359778f8144a9102b8edbaf3c6885e304c7c /PKGBUILD
parentb1fbe521928f5105c0b77e335146d31ffca86173 (diff)
downloadaur-c20633c1a3c685ae419bd5b9b5ff778019f0744d.tar.gz
Add support for aarch64
Also disables symbol stripping, because it takes a lot of time and source is stripped already.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 08cf8d57270c..eea882e8b270 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,18 +4,21 @@ pkgver=0.9.1
pkgrel=1
epoch=
pkgdesc="robust, optimal, and clear programming language"
-arch=('x86_64')
+arch=('x86_64' 'aarch64')
url="https://ziglang.org/"
license=('MIT')
depends=()
makedepends=()
+options=('!strip')
provides=('zig')
conflicts=('zig')
-source=("https://ziglang.org/download/$pkgver/zig-linux-x86_64-$pkgver.tar.xz")
-md5sums=('01daf426d9e1c86aad6e4b26351e1ae8')
+source_x86_64=("https://ziglang.org/download/$pkgver/zig-linux-x86_64-$pkgver.tar.xz")
+source_aarch64=("https://ziglang.org/download/$pkgver/zig-linux-aarch64-$pkgver.tar.xz")
+md5sums_x86_64=('01daf426d9e1c86aad6e4b26351e1ae8')
+md5sums_aarch64=('d7b665a034281572664ed73fc3ec6684')
package() {
- cd "$srcdir/zig-linux-x86_64-$pkgver"
+ cd "$srcdir/zig-linux-${CARCH}-$pkgver"
install -D zig "$pkgdir/usr/bin/zig"
install -D LICENSE "$pkgdir/usr/share/licenses/zig/LICENSE"
cp -r lib "$pkgdir/usr"