summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDeimos2018-08-29 19:05:46 -0400
committerDeimos2018-08-29 19:05:46 -0400
commitab0da1318ffe5b311da8d5e5ebd78e0befbba130 (patch)
tree479b95f9340a7736c01b097cb7945bcf210b0fd1 /PKGBUILD
parentaa90ec867c919d9e1d88d30079d91089e380774d (diff)
downloadaur-ab0da1318ffe5b311da8d5e5ebd78e0befbba130.tar.gz
Build Reliability
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 9 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b7724184ce72..2ff85510d799 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,15 @@
-# Maintainer: Thomas Ascher <thomas.ascher@gmx.at>
-# Contributor: Thomas Ascher <thomas.ascher@gmx.at>
+# Maintainer: Icarus Mitchellson <mumei AT airmail DOT cc>
+
pkgname=zipper.app
_pkgname=Zipper
pkgrel=1
pkgver=1.5
-pkgdesc="Multi-format archive extractor with compression services."
+pkgdesc="Multi-format archive extractor with compression services"
arch=('i686' 'x86_64')
url="http://www.nongnu.org/gap/zipper/index.html"
license=('GPL')
-groups=('gnustep')
-depends=('gnustep-base'
- 'gnustep-gui')
+groups=('gnustep-apps')
+depends=('gnustep-base' 'gnustep-gui')
optdepends=('arj'
'bzip2'
'gzip'
@@ -21,31 +20,18 @@ optdepends=('arj'
'unarj'
'unrar'
'zoo')
-makedepends=('gcc-objc'
- 'gnustep-make')
+makedepends=('gcc-objc' 'gnustep-make')
source=("http://savannah.nongnu.org/download/gap/$_pkgname-$pkgver.tar.gz")
sha256sums=('3ecf9cd7e2242c62e38a4933ce4f3da35e90f52ca94ac030a1f2a717e6561392')
build() {
cd "$_pkgname-$pkgver"
+ export GNUSTEP_MAKEFILES="$(gnustep-config --variable=GNUSTEP_MAKEFILES)"
make
}
package() {
cd "$_pkgname-$pkgver"
make DESTDIR="$pkgdir/" install
- install -D -m644 "$pkgdir/usr/lib/GNUstep/Applications/$_pkgname.app/Resources/$_pkgname.desktop" \
- "$pkgdir/usr/share/applications/$_pkgname.desktop"
-}
-
-post_install() {
- update-desktop-database -q
-}
-
-post_upgrade() {
- post_install $1
-}
-
-post_remove() {
- post_install $1
-}
+ install -Dm644 "$pkgdir/usr/lib/GNUstep/Applications/$_pkgname.app/Resources/$_pkgname.desktop" "$pkgdir/usr/share/applications/$_pkgname.desktop"
+} \ No newline at end of file