summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSven Hebrok2023-01-13 10:14:40 +0100
committerSven Hebrok2023-01-13 10:14:40 +0100
commite27d54c412fb8ee14376e530292822b3ac00816d (patch)
tree4e67c3a4c0c9e9c5bd92a9c47641ca3afd3523e2 /PKGBUILD
parent539d531ed5d907c5ec4b8c13ae3a6dd832010469 (diff)
downloadaur-e27d54c412fb8ee14376e530292822b3ac00816d.tar.gz
Fix pkgbuild
- Remove dependencies not listed in zmaps INSTALL (also I did not have these packages installed and it compiled :shrug:) - Update blacklist -> blocklist as done in zmap 3.0.0 - Also add a gitignore
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 733d1f06a725..640c7d1eb4c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
-# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Maintainer: Sven Hebrok <xoimex[at]gmail[dot]org>
+# Contributor: Levente Polyak <anthraxx[at]archlinux[dot]org>
# Contributor: Jens Adam <jra@byte.cx>
# Contributor: Arch3y <arch3y[at]archstrike[dot]org>
pkgname=zmap-git
-pkgver=2.1.1.1031.369bff3
+pkgver=3.0.0.1215.118b910-1
pkgrel=1
pkgdesc='Fast network scanner designed for Internet-wide network surveys'
url='https://zmap.io/'
arch=('i686' 'x86_64')
license=('Apache')
-depends=('gmp' 'hiredis' 'json-c' 'libpcap' 'libmongoc')
+depends=('gmp' 'json-c' 'libpcap')
makedepends=('git' 'byacc' 'cmake' 'gengetopt' 'pkg-config')
provides=('zmap')
conflicts=('zmap')
-backup=('etc/zmap/blacklist.conf' 'etc/zmap/zmap.conf')
+backup=('etc/zmap/blocklist.conf' 'etc/zmap/zmap.conf')
source=(${pkgname}::git+https://github.com/zmap/zmap.git)
sha512sums=('SKIP')
@@ -33,7 +34,7 @@ build() {
package() {
cd ${pkgname}
- install -Dm 755 src/{zmap,ztee,zblacklist} -t "${pkgdir}/usr/bin"
+ install -Dm 755 src/{zmap,ztee,zblocklist} -t "${pkgdir}/usr/bin"
install -Dm 644 src/*.1 -t "${pkgdir}/usr/share/man/man1"
install -Dm 644 conf/* -t "${pkgdir}/etc/zmap"
install -Dm 644 AUTHORS CHANGELOG.md INSTALL.md README.md \