summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYuhanun Citgez2020-02-22 21:31:47 -0500
committerYuhanun Citgez2020-02-22 21:31:47 -0500
commitca8f7ded878a64f9e6bba93a042440fa80ff2a73 (patch)
tree2f5209c8efe90624bc23a5ad64c3dda106330493 /PKGBUILD
downloadaur-ca8f7ded878a64f9e6bba93a042440fa80ff2a73.tar.gz
Initial push for zmqpp-git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..44485da9c991
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Yuhanun Citgez <y dot citgez at student dot utwente dot nl>
+
+pkgname=zmqpp-git
+pkgver=1
+pkgrel=1
+commit_hash=7f099a8dba534661c69db32e31e13f06f34ad6bc
+pkgdesc="ZMQPP's latest version"
+arch=('x86_64')
+url='https://github.com/zeromq/zmqpp'
+licence=('MIT')
+depends=('libsodium' 'zeromq')
+makedepends=('make')
+provides=('libzmqpp')
+source=("git+$url#commit=$commit_hash")
+md5sums=('SKIP')
+
+prepare() {
+ cd zmqpp
+ git submodule update --init --recursive
+}
+
+build() {
+ cd zmqpp
+ make
+}
+
+# check() {
+# make check
+# }
+
+package() {
+ cd zmqpp/build/max-g++
+ mkdir -p "${pkgdir}"/opt/zmqpp-git
+ install -Dm666 libzmqpp.a "${pkgdir}/opt/zmqpp-git/libzmqpp.a"
+
+ mkdir -p "${pkgdir}/usr/lib"
+ ln -s /opt/zmqpp-git/libzmqpp.a "${pkgdir}/usr/lib/libzmqpp.a"
+}