summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSTREBLO2016-05-30 15:49:35 -0700
committerSTREBLO2016-05-30 16:07:03 -0700
commitdbe1ab16a9e08260244b515ee7fa62bf71407ba9 (patch)
tree6bb700ba323373dbfc6032dec7853db7cab83d95 /PKGBUILD
downloadaur-dbe1ab16a9e08260244b515ee7fa62bf71407ba9.tar.gz
Added .gitignore and made PKGBUILD and .SRCINFO
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..19a2ea4e492b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: John Ramsden <streblo@ramsdenj.ca>
+pkgname=znapzend
+pkgver=0.15.7
+pkgrel=1
+pkgdesc="ZnapZend is a ZFS centric backup tool. It relies on snapshot, send and receive todo its work. It has the built-in ability to manage both local snapshots as well as remote copies by thining them out as time progresses."
+arch=('any')
+url="http://www.znapzend.org/"
+license=('GPL')
+makedepends=('perl')
+source=("https://github.com/oetiker/${pkgname}/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
+noextract=()
+md5sums=('c464e0799212f025c31859737c3ce4bc')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ ./configure --prefix="/opt/${pkgname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ mkdir -p "${pkgdir}/usr/bin" "${pkgdir}/etc/systemd/system" "${pkgdir}/usr/share/man/man1"
+ ln -s "/opt/${pkgname}-${pkgver}/bin/znapzend" "${pkgdir}/usr/bin/znapzend"
+ ln -s "/opt/${pkgname}-${pkgver}/bin/znapzendzetup" "${pkgdir}/usr/bin/znapzendzetup"
+ ln -s "/opt/${pkgname}-${pkgver}/bin/znapzendztatz" "${pkgdir}/usr/bin/znapzendztatz"
+ cp "init/znapzend.service" "${pkgdir}/etc/systemd/system/"
+ cp "man/znapzend.1" "man/znapzendzetup.1" "man/znapzendztatz.1" "${pkgdir}/usr/share/man/man1"
+}