summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJosef Vybíhal2022-03-23 09:10:38 +0100
committerJosef Vybíhal2022-03-23 09:10:38 +0100
commit8dfe9123332644b9476451b93e9cd32328cc9d5c (patch)
treea0b0be172557fe887f1f9dd5da9580100a528397 /PKGBUILD
downloadaur-8dfe9123332644b9476451b93e9cd32328cc9d5c.tar.gz
Init of FiSH Module for ZNC. Source from qnorsten/znc-fish - seems to be the most fresh one
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..09745dda1a80
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+pkgname=znc-fish
+pkgver=r21.dfc4408
+pkgrel=1
+pkgdesc='FiSH Module for ZNC'
+arch=('x86_64')
+url='https://github.com/qnorsten/znc-fish'
+license=('GPL')
+depends=('znc')
+makedepends=('cmake')
+provides=('znc-fish')
+#conflicts=('')
+source=('git+https://github.com/qnorsten/znc-fish.git')
+b2sums=('SKIP')
+_gitname='znc-fish'
+
+pkgver() {
+ cd "$_gitname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_gitname"
+ znc-buildmod fish.cpp
+}
+
+package() {
+ cd "$_gitname"
+ install -Dm755 fish.so "${pkgdir}/usr/lib/znc/fish.so"
+}