summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHunter Wittenborn2021-02-22 03:10:20 -0600
committerHunter Wittenborn2021-02-22 03:10:20 -0600
commit15152309d985aaae2c81f015fe18bed246534a3d (patch)
tree70915d91efac91e0d06443d0c14a909e87343933 /PKGBUILD
parent27ad47f9423481e986a7bf6b485383ca8c5f6b7b (diff)
downloadaur-15152309d985aaae2c81f015fe18bed246534a3d.tar.gz
Updated to 1.1.12; other updates
- Updated to 1.1.12 - Redone for support with latest release - Dropped support for i386(only x86_64 for now)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD63
1 files changed, 26 insertions, 37 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7ce3426a1428..a7d058f6292b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,33 @@
-# Maintainer: Emerson Almeida <duke.m16@gmail.com>
-# Contributor: Emerson Almeida <duke.m16@gmail.com>
+# Maintainer: Hunter Wittenborn <hunter@hunterwittenborn.me>
+# Past Maintainer: Emerson Almeida <duke.m16@gmail.com>
+# Past Contributor: Emerson Almeida <duke.m16@gmail.com>
pkgname=zoho-mail-desktop
-pkgver=1.0.0
+pkgver=1.1.12
pkgrel=1
-pkgdesc="A desktop version of your favorite mailsuite!"
-arch=('x86_64' 'i686')
-license=('custom:"Copyright (c) 2018, Zoho Corporation Pvt. Ltd."')
-url="https://www.zoho.com/mail"
-options=('!strip' '!upx')
+pkgdesc="The desktop version of your favorite mailsuite!"
+arch=('x86_64')
+license=('custom')
+url="https://www.zoho.com/mail/"
+options=()
-sha256sums_x86_64=('981bf5cfe72519a210793b4ac02d4beee40bfe651ac873c95b375a8429a37c88')
-sha256sums_i686=('8f7c4477099b5bda4ecb74d78591c0a432d5311bd8dc5e379798812f7c1bb1c6')
+sha256sums_x86_64=('fb4e7e60f1e06ebb6d3d285e380da7251f74c97b6bc786635648e73fd2cf4762')
+source_x86_64=("https://downloads.zohocdn.com/zmail-desktop/linux/zoho-mail-desktop-x64-v${pkgver}.AppImage")
-source_x86_64=("https://www.zoho.com/mail/desktop/linux/installer-x64-${pkgver}.deb")
-source_i686=("https://www.zoho.com/mail/desktop/linux/installer-x86-${pkgver}.deb")
-
-provides=(
- 'libnode'
- 'libffmpeg'
-)
-
-depends=(
- 'nss'
- 'libxtst'
- 'alsa-lib'
- 'libxss'
- 'gtk2'
- 'gconf'
-)
+prepare() {
+ chmod +x zoho-mail-desktop-x64-v${pkgver}.AppImage
+ ./zoho-mail-desktop-x64-v${pkgver}.AppImage --appimage-extract
+ }
package() {
- cd "${srcdir}"
-
- tar -xf data.tar.xz -C "${pkgdir}"
-
- for size in 22 24 32 48 64 128 256 512; do
- install -D "${pkgdir}/usr/share/pixmaps/zoho-mail-desktop.png" \
- "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps/zoho-mail-desktop.png"
- done
-
- chmod -R go-w "${pkgdir}"/usr
-}
+ mkdir -p "${pkgdir}/opt/"
+ cp -R "${srcdir}/squashfs-root/" "${pkgdir}/opt/${pkgname}"
+ chmod -R 755 "${pkgdir}/opt/${pkgname}"
+
+ mkdir -p "${pkgdir}/usr/share/"
+ cp -R "${srcdir}/squashfs-root/usr/share/icons/" "${pkgdir}/usr/share/"
+
+ mkdir -p "${pkgdir}/usr/share/applications/"
+ cp "../zoho-mail-desktop.desktop" "${pkgdir}/usr/share/applications/"
+ }
+