summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTroy Will2016-01-10 13:59:50 -0800
committerTroy Will2016-01-10 13:59:50 -0800
commitad2f482b3d9cf6e66f7377665ed32ce62f6c495e (patch)
tree06a3c433304b5197d704745ba7105d7d787c814d /PKGBUILD
parentb6297f82ac641094ab3f82bba724eaba1485b8e5 (diff)
downloadaur-ad2f482b3d9cf6e66f7377665ed32ce62f6c495e.tar.gz
PKGBUILD: modify git submodule update
zoneminder.install: modify for PHP7
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 25129f078b5b..a75cd24b281d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@
_pkgname=zoneminder
pkgname=zoneminder-git
pkgver=1.29.0
-pkgrel=2
+pkgrel=3
pkgdesc='Capture, analyse, record and monitor video security cameras'
arch=( i686 x86_64 mips64el arm armv7h )
backup=( etc/zm.conf )
@@ -41,12 +41,14 @@ install=$_pkgname.install
source=(
git://github.com/$_pkgname/$_pkgname.git
+ git://github.com/FriendsOfCake/crud.git
httpd-zoneminder.conf
zoneminder.service
zoneminder-tmpfile.conf
)
# Because the source is not static, skip Git checksum:
sha256sums=('SKIP'
+ 'SKIP'
'ff7382b38ac07dadead0ad4d583e3dbcf8da4aaa06b76d048ee334f69f95db67'
'043d77a995553c533d62f48db4b719d29cf6c7074f215d866130e97be57ed646'
'cc8af737c3c07750fc71317c81999376e4bbb39da883780164a8747b3d7c95a7'
@@ -60,7 +62,10 @@ pkgver() {
prepare () {
cd $srcdir/$_pkgname
- git submodule update --init --recursive
+ git submodule init
+ git config submodule.web/api/app/Plugin/Crud.url $srcdir/crud
+ git config submodule.web/api/app/Plugin/Crud.branch 3.0
+ git submodule update
}
build() {