summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJanghyub Seo2021-08-25 14:41:54 +0900
committerJanghyub Seo2021-08-25 14:41:54 +0900
commit8f870767948f5a7f8731aa2000b2c3496a55af0b (patch)
tree0b2a9836215237a2e368ec029c9cccce56e9d7db /PKGBUILD
downloadaur-8f870767948f5a7f8731aa2000b2c3496a55af0b.tar.gz
kime 2.5.5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d988959fc1b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Janghyub Seo <jhyub06 at gmail dot com>
+pkgname=zoom-libkime
+pkgver=2.5.5
+pkgrel=1
+pkgdesc="Kime library for zoom which embeds qt itself"
+arch=('x86_64')
+url="https://github.com/Riey/kime"
+license=('GPL3')
+depends=('kime' 'zoom')
+makedepends=('docker')
+source=(
+ kime-${pkgver}.tar.gz::"${url}/archive/v${pkgver}.tar.gz"
+)
+md5sums=('dea5c3079478d5ec33f272b372751a88')
+
+build() {
+ cd "kime-${pkgver}"
+ docker rm kime
+ docker build --file build-docker/ubuntu-20.04/Dockerfile --tag kime-build:git .
+ docker run --name kime kime-build:git
+}
+
+package() {
+ cd "kime-${pkgver}"
+ docker cp kime:/opt/kime/build/out/libkime-qt5.so libkimeplatforminputcontextplugin.so
+ install -Dm755 libkimeplatforminputcontextplugin.so -t "${pkgdir}/opt/zoom/platforminputcontexts"
+}