summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicolas F2015-08-15 21:25:04 +0200
committerNicolas F2015-08-15 21:25:04 +0200
commite627e564a04e4aeee339558018d8e591d7ab5791 (patch)
treea4deca8c35b348c8c4e400c4058958e80a3116e4 /PKGBUILD
parent1370db16fac8623d57039c763ef9d1404f7001de (diff)
downloadaur-e627e564a04e4aeee339558018d8e591d7ab5791.tar.gz
Better pkgver function
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 13f30be0a05e..405f366da92c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Nicolas F. <aur@fratti.ch>
pkgname=zopflipng-git
-pkgver=6ff3ba2
-pkgrel=2
+pkgver=1.0.0.r31.g6ff3ba2
+pkgrel=1
pkgdesc="PNG optimisation tool using Google's zopfli library, git version."
arch=('i686' 'x86_64' 'ARM')
url="https://github.com/google/zopfli"
@@ -14,7 +14,7 @@ md5sums=('SKIP')
pkgver() {
cd "$srcdir/zopfli"
- printf "%s" "$(git rev-parse --short HEAD)"
+ git describe | sed -r 's/zopfli-//; s/([^-]*-g)/r\1/; s/-/./g'
}
build() {