summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJuanma Hernández2017-07-13 07:10:01 +0200
committerJuanma Hernández2017-07-13 07:10:01 +0200
commita02e7011f3cd8d34ad9541d2a3c260cbaf9676db (patch)
treea52f637c6542e2221fd9055e73af62975a67aece /PKGBUILD
parent69ff7bf626fd7753e1ecc4300355b4c9a35d35a8 (diff)
downloadaur-a02e7011f3cd8d34ad9541d2a3c260cbaf9676db.tar.gz
Update to version 5.0.2. Applied suggested changes in comments and in namcap
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 12 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index da676527f4ba..67e7174b0058 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,30 +2,27 @@
# Maintainer: Juanma Hernandez <juanmah@gmail.com>
pkgname=zotero
-pkgver=5.0.1
-pkgrel=1
+pkgver=5.0.2
+pkgrel=3
pkgdesc="Zotero Standalone. Is a free, easy-to-use tool to help you collect, organize, cite, and share your research sources."
arch=('i686' 'x86_64')
url="http://www.zotero.org/download"
license=('GPL3')
depends=('dbus-glib' 'alsa-lib' 'gtk2' 'gcc-libs' 'nss')
-if [[ $CARCH == "x86_64" ]]
-then
- _arch=x86_64
- md5sums=('969dbbc0bfaf1385d455d7fcae22e109'
- 'f227abe95940abd63367716928c6e379')
-else
- _arch=i686
- md5sums=('a8dc90f2c894581afd0afb11294f8882'
- 'f227abe95940abd63367716928c6e379')
-fi
+
+md5sums=('f227abe95940abd63367716928c6e379')
+md5sums_i686=('1dd4fba22dc4718359e789d9df2b4afd')
+md5sums_x86_64=('b154fa051050c6cb4431dacca0278ba8')
+
install='zotero.install'
-source=("http://download.zotero.org/standalone/$pkgver/Zotero-${pkgver}_linux-${_arch}.tar.bz2"
- "zotero.desktop")
+
+source=("zotero.desktop")
+source_i686=("Zotero-${pkgver}_linux_$CARCH.tar.bz2::https://www.zotero.org/download/client/dl?channel=release&platform=linux-$CARCH&version=${pkgver}")
+source_x86_64=("Zotero-${pkgver}_linux_$CARCH.tar.bz2::https://www.zotero.org/download/client/dl?channel=release&platform=linux-$CARCH&version=${pkgver}")
package() {
mkdir -p "$pkgdir"/usr/{bin,lib/zotero}
- mv "$srcdir"/Zotero_linux-$_arch/* "$pkgdir"/usr/lib/zotero
+ mv "$srcdir"/Zotero_linux-$CARCH/* "$pkgdir"/usr/lib/zotero
ln -s /usr/lib/zotero/zotero "$pkgdir"/usr/bin/zotero
install -Dm644 "$srcdir"/zotero.desktop "$pkgdir"/usr/share/applications/zotero.desktop
# Copy zotero icons to a standard location