summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSnipeX_2023-07-31 16:58:48 +0200
committerSnipeX_2023-07-31 16:58:48 +0200
commitfe8d45e5f4d53dd3d1e7dda9569f2626d960d365 (patch)
tree0489847b0539b70a3e807497d6139c5894e0e563 /PKGBUILD
downloadaur-fe8d45e5f4d53dd3d1e7dda9569f2626d960d365.tar.gz
Initial commit; zotify 0.6.11
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b930a9658f0d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Andrej Halveland (SnipeX_) <andrej.halv@gmail.com>
+
+pkgname=zotify
+pkgver=0.6.11
+_commit=91f24a81f2812cc3195f17a5308119cee5b2c435 # 0.6.11
+pkgrel=1
+pkgdesc="A fast and customizable music and podcast downloader."
+arch=('x86_64')
+url="https://zotify.xyz/zotify/zotify"
+license=('custom')
+depends=(
+ 'python'
+ 'python-librespot'
+ 'python-music-tag'
+ 'python-pillow'
+ 'python-protobuf'
+ 'python-tabulate'
+ 'python-tqdm'
+ 'python-ffmpy'
+ 'python-pwinput'
+ 'python-mutagen'
+)
+makedepends=(
+ 'git'
+ 'python-setuptools'
+ 'python-build'
+ 'python-wheel'
+ 'python-installer'
+)
+source=("zotify::git+https://zotify.xyz/zotify/zotify#commit=$_commit")
+sha256sums=('SKIP')
+
+build() {
+ cd zotify
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd zotify
+ python -m installer --destdir="${pkgdir}" dist/*.whl
+ mkdir -p "${pkgdir}/usr/bin"
+
+ cat <<EOF >"${pkgdir}/usr/bin/zotify"
+#!/bin/sh
+python -m zotify \$@
+EOF
+
+ chmod +x "${pkgdir}/usr/bin/zotify"
+ install -Dm644 LICENSE -t "${pkgdir}"/usr/share/licenses/${pkgname}/
+}