summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoryuhr2017-06-15 02:08:51 +0900
committeryuhr2017-06-15 02:08:51 +0900
commit2446242a130e0ab4cec4c770fbb23290e2f0af9d (patch)
tree59db976211b320b175ed4ff3ab69061e4cdcaa26 /PKGBUILD
parent52dbfadbc6da6165086a67080225ebe3dbf7b2d3 (diff)
downloadaur-2446242a130e0ab4cec4c770fbb23290e2f0af9d.tar.gz
fix problems caused by wrong permission
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0da010037b98..7c9110fef5dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=zpdic
pkgver=1.15.1
-pkgrel=1
+pkgrel=2
pkgdesc="A modern solution for editing dictionaries."
url="http://ziphil.web.fc2.com/application/download/2.html"
license=('custom')
@@ -24,7 +24,12 @@ package() {
unzip "v${pkgver}-full.zip" -d "v${pkgver}-full"
cd "v${pkgver}-full"
- for f in `find -type f` ; do
- install -Dm644 {,"${pkgdir}/usr/share/${pkgname}/"}"${f}"
+ install -dm777 "${pkgdir}/opt/${pkgname}"
+ for path in `find` ; do
+ if [ -d "${path}" ] ; then
+ install -dm777 "${pkgdir}/opt/${pkgname}/${path}"
+ elif [ -f "${path}" ] ; then
+ install -m644 {,"${pkgdir}/opt/${pkgname}/"}"${path}"
+ fi
done
}