summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfennecdjay2017-02-17 00:53:25 +0100
committerfennecdjay2017-02-17 00:53:25 +0100
commit477087bff33365ff79ccf20ac93375d04f9c645d (patch)
tree183048f3e083a15e06eb15ab7687e456b2bdd3df /PKGBUILD
downloadaur-477087bff33365ff79ccf20ac93375d04f9c645d.tar.gz
initial commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ffdd56134497
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Jérémie Astor <astor.jeremie@wanadoo.fr>
+pkgname=zpm-zsh
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="zsh plugin manager in ansi C."
+arch=(any)
+url="https://github.com/zpm-project/zpm-zsh"
+license=('GPL')
+source=(https://github.com/zpm-project/zpm-zsh/archive/v$pkgver.tar.gz)
+md5sums=('a63830a25b92e5714477d982c983dfd7')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ git clone $(cat .gitmodules | grep "url =" | cut -d "=" -f2)
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ mkdir -p "$pkgdir/bin"
+ PREFIX="$pkgdir" make install
+}