summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authororhun2019-10-15 07:44:35 +0300
committerorhun2019-10-15 07:44:35 +0300
commit671b2ec0cf285b972c2b13251c604de9000575b4 (patch)
tree5bb0697c7b7629bb0a0402935e2e40a21192b614 /PKGBUILD
downloadaur-671b2ec0cf285b972c2b13251c604de9000575b4.tar.gz
Initial release (0.1)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..635f0bafd53f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: orhun <github.com/orhun>
+pkgname=zps-git
+pkgdesc="A small utility for listing or cleaning up zombie processes."
+pkgver=0.1.r4.gd598df1
+pkgrel=1
+arch=('any')
+url="https://github.com/orhun/zps"
+license=('GPL3')
+makedepends=('cmake')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('git://github.com/orhun/zps.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ mkdir -p "${pkgname%-git}/build"
+ cd "${pkgname%-git}/build"
+ cmake ../ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "${pkgname%-git}/build"
+ make DESTDIR="$pkgdir" install
+}