summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohn Ramsden2019-10-14 12:36:50 -0700
committerJohn Ramsden2019-10-14 12:36:50 -0700
commit79db56e135776441fc10260687cbb2953e78989a (patch)
tree4aaa22c8aabaca995db90a90e9832541a1059273 /PKGBUILD
parent96f34aa23e5154f9f4c91c4d92e633a8c78909ce (diff)
downloadaur-79db56e135776441fc10260687cbb2953e78989a.tar.gz
Add arch to version string
See https://github.com/zrepl/zrepl/pull/228
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a1e5d1d24a89..a8e536d134d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=zrepl
pkgver=0.2.0
-pkgrel=2
+pkgrel=3
pkgdesc='One-stop ZFS backup & replication solution'
arch=('x86_64')
url='https://zrepl.github.io/'
@@ -13,11 +13,15 @@ depends=('go-pie')
source=("https://github.com/${pkgname}/${pkgname}/archive/v${pkgver}.tar.gz")
sha256sums=('40ceb559059b43e96f61303a43ca0fac80b26f8281a07aa03e235658a6548891')
+zrepl_version="arch-${pkgver}"
+
build() {
+ GO_LDFLAGS="-X github.com/zrepl/zrepl/version.zreplVersion=${zrepl_version}"
cd "${pkgname}-${pkgver}"
go build \
-trimpath \
- -ldflags "-extldflags ${LDFLAGS}" \
+ -mod=readonly \
+ -ldflags "${GO_LDFLAGS} -extldflags ${LDFLAGS}" \
-o "${pkgname}" .
}