summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohn Ramsden2020-03-15 15:10:02 -0700
committerJohn Ramsden2020-03-15 15:13:13 -0700
commitde8e44bc9215cf26fd7361a9d90b23ba53905f51 (patch)
treecf2d90e2f7aa72022fa9a575ff7f2682ead33e5c /PKGBUILD
parent6a013df20ba510a82f5275f865fda230d02448c2 (diff)
downloadaur-de8e44bc9215cf26fd7361a9d90b23ba53905f51.tar.gz
Stop using go-pie in favor of -buildmode=pie
See: * lists.archlinux.org/pipermail/arch-dev-public/2020-March/029898.html
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4a207c82a5a9..bc5f5481c31d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgname=zrepl
pkgver=0.2.1
-pkgrel=1
+pkgrel=2
pkgdesc='One-stop ZFS backup & replication solution'
arch=('x86_64')
url='https://zrepl.github.io/'
license=('MIT')
provides=('zrepl')
conflicts=('zrepl-bin')
-depends=('go-pie')
+depends=('go')
source=("https://github.com/${pkgname}/${pkgname}/archive/v${pkgver}.tar.gz")
sha256sums=('df474e70f5a51d84816ee8a06038ded167a7548e547e2d2822c313f088eeeafd')
@@ -20,7 +20,10 @@ build() {
cd "${pkgname}-${pkgver}"
go build \
-trimpath \
+ -buildmode=pie \
+ -mod=vendor \
-mod=readonly \
+ -modcacherw \
-ldflags "${GO_LDFLAGS} -extldflags ${LDFLAGS}" \
-o "${pkgname}" .
}