summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSefa Eyeoglu2022-09-11 12:26:04 +0200
committerSefa Eyeoglu2022-09-11 12:26:04 +0200
commit04d03e108d55ee5bb52aeba0b8aacc4a1d3426f1 (patch)
treef62fe82e70875b6dfc9e90a40799002de7182688 /PKGBUILD
parent9f047124184a26a64dc31095ea419112035b7d6a (diff)
downloadaur-04d03e108d55ee5bb52aeba0b8aacc4a1d3426f1.tar.gz
upgpkg: zrythm 1.0.0.beta.3.4.1-1
upstream release this works for now
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 23 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dd5cf90b5d6b..e12270929c99 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,26 @@
# Contributor: Alexandros Theodotou <alex at zrythm dot org>
pkgname=zrythm
-_pkgver=1.0.0-beta.2.0.3
+_pkgver=1.0.0-beta.3.4.1
pkgver=${_pkgver/-/.}
-pkgrel=3
+pkgrel=1
pkgdesc='a highly automated and intuitive digital audio workstation'
arch=('x86_64' 'i686')
url="https://www.zrythm.org"
license=('AGPL3')
-depends=('gtk4' 'graphviz' 'carla' 'fluidsynth' 'vamp-plugin-sdk' 'guile' 'libaudec' 'xxhash' 'libcyaml' 'libadwaita' 'reproc' 'libbacktrace' 'rubberband' 'gtksourceview5' 'fftw' 'sratom' 'serd' 'portaudio' 'breeze-icons' 'rtmidi' 'rtaudio' 'lsp-dsp-lib' 'sdl2' 'chromaprint' 'boost' 'lilv')
-makedepends=('meson' 'cmake' 'ruby-sass' 'help2man' 'sassc')
+depends=('gtk4' 'gtksourceview5' 'graphviz' 'carla' 'fluidsynth' 'vamp-plugin-sdk' 'guile' 'libaudec' 'xxhash' 'libcyaml' 'reproc' 'libbacktrace' 'rubberband' 'fftw' 'sratom' 'serd' 'portaudio' 'breeze-icons' 'rtmidi' 'rtaudio' 'lsp-dsp-lib' 'sdl2' 'chromaprint' 'boost' 'dconf' 'libxrandr' 'graphene' 'libepoxy' 'json-glib' 'libxinerama' 'lilv')
+makedepends=('git' 'meson' 'cmake' 'ruby-sass' 'help2man' 'sassc')
optdepends=('realtime-privileges: allow memory locking')
-conflicts=('zrythm-git')
+conflicts=('zrythm-git' 'libadwaita' 'libpanel') # TODO: statically link?
options=('debug')
-source=("https://www.zrythm.org/releases/$pkgname-$_pkgver.tar.xz"{,.asc})
-sha256sums=('46258667a26e40a8cbd50c7363054a6dc48d51acb41284cbb97142c3dd9af6a1'
+source=("https://www.zrythm.org/releases/$pkgname-$_pkgver.tar.xz"{,.asc}
+ "git+https://gitlab.gnome.org/GNOME/libadwaita.git"
+ "git+https://gitlab.gnome.org/GNOME/libpanel.git"
+ "git+https://github.com/drobilla/zix.git")
+sha256sums=('c928eeb5a3010e49164fd6e858d0a8b1c1210e00a3c3d1b817cde5b7c1944505'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
'SKIP')
validpgpkeys=('48132384AD3DF7D86E254B83022EAE42313D70F3')
@@ -23,15 +29,21 @@ validpgpkeys=('48132384AD3DF7D86E254B83022EAE42313D70F3')
prepare() {
cd "$pkgname-$_pkgver"
- rm -r subprojects
+ # use our local clones
+ sed -i "s|https://gitlab.gnome.org/GNOME/libadwaita|$srcdir/libadwaita|" "subprojects/libadwaita.wrap"
+ sed -i "s|https://gitlab.gnome.org/GNOME/libpanel|$srcdir/libpanel|" "subprojects/libpanel.wrap"
+ sed -i "s|https://github.com/drobilla/zix|$srcdir/zix|" "subprojects/zix.wrap"
+ meson subprojects download libadwaita libpanel zix
}
build() {
cd "$pkgname-$_pkgver"
- # TODO: tests
+ # TODO: static link everything, gtk4 as well
meson build --prefix=/usr \
- -Doptimization=3 -Ddebug=true \
+ --wrap-mode nofallback \
+ --force-fallback-for=libpanel-1,libadwaita-1,zix-0 \
+ -Ddebug=true \
-Dmanpage=true \
-Dcheck_updates=false \
-Dportaudio=enabled -Drtmidi=enabled -Drtaudio=enabled -Dsdl=enabled
@@ -44,5 +56,5 @@ package() {
install -vDm 644 AUTHORS CONTRIBUTING.md \
CHANGELOG.md README.md THANKS TRANSLATORS \
-t "${pkgdir}/usr/share/doc/${pkgname}/"
- DESTDIR="${pkgdir}/" ninja -C build install
+ meson install -C build --destdir="$pkgdir"
}