summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoralextee2019-01-01 17:00:47 +0000
committeralextee2019-01-01 17:00:47 +0000
commit4b0179a899ee3b7d3c0ca0312bb9b4835f70529f (patch)
tree3be5b69661191f20cc97fb6ed7175cb6b63ee381 /PKGBUILD
downloadaur-4b0179a899ee3b7d3c0ca0312bb9b4835f70529f.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b01cad06b4d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Alexandros Theodotou <alex at alextee dot org>
+
+pkgname=zrythm
+pkgver=master
+pkgrel=1
+pkgdesc="Free GNU/Linux music production system (DAW)"
+arch=('x86_64')
+url="https://gitlab.com/alextee/zrythm"
+license=('GPL3')
+depends=('gtk3' 'lv2' 'lilv' 'suil' 'jack' 'libsndfile' 'libsmf' 'libdazzle')
+source=("https://gitlab.com/alextee/zrythm/-/archive/$pkgver/zrythm-$pkgver.tar.gz")
+md5sums=('SKIP')
+
+prepare() {
+ cd "zrythm-$pkgver"
+}
+
+build() {
+ cd "zrythm-$pkgver"
+ autoreconf -fi
+ ./configure --prefix=/usr --enable-aur-build
+ make
+}
+
+package() {
+ cd "zrythm-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}