summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoralextee2019-01-01 14:24:36 +0000
committeralextee2019-01-01 14:24:36 +0000
commitbd4d103636b813525cf330e5fde4b261d048dcb4 (patch)
tree1a7885265df6015c57a8d3e49b53f9aaff4625ab /PKGBUILD
parente51effc50b6a337f1fa9f6b0046ca4dde78d7da3 (diff)
downloadaur-bd4d103636b813525cf330e5fde4b261d048dcb4.tar.gz
use tarball instead of git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e8fa406a70e0..73996f81420d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,29 @@
# Maintainer: Alexandros Theodotou <alex at alextee dot online>
pkgname=zrythm-git
-pkgver=0.1
-pkgrel=2
+pkgver=master
+pkgrel=3
pkgdesc="Free GNU/Linux music production system (DAW)"
arch=('x86_64')
url="https://gitlab.com/alextee/zrythm"
license=('GPL')
depends=('gtk3' 'lv2' 'lilv-git' 'suil-git' 'jack' 'libsndfile' 'libsmf')
-makedepends=('git')
-source=("$pkgname-$pkgver::git+https://gitlab.com/alextee/zrythm.git")
+source=("https://gitlab.com/alextee/zrythm/-/archive/$pkgver/zrythm-$pkgver.tar.gz")
md5sums=('SKIP')
prepare() {
- cd "$pkgname-$pkgver"
+ cd "zrythm-$pkgver"
}
build() {
- cd "$pkgname-$pkgver"
+ cd "zrythm-$pkgver"
autoreconf -fi
./configure --prefix=/usr --enable-aur-build
make
}
package() {
- cd "$pkgname-$pkgver"
+ cd "zrythm-$pkgver"
make DESTDIR="$pkgdir/" install
}