summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Patrick Fair2020-10-16 08:37:17 -0600
committerChristopher Patrick Fair2020-10-16 08:37:17 -0600
commit82e6523e40e2d7326a096a50831a790b9f5fd2cc (patch)
tree6a0eda944eb346cb7ca007273d2cdbb2e015de42 /PKGBUILD
parent198ea9f002d3f70587f8fcb1aee18b5709ff5917 (diff)
downloadaur-82e6523e40e2d7326a096a50831a790b9f5fd2cc.tar.gz
modified: .SRCINFO
modified: PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 64bea93c7140..ca7a776ca6db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,6 +2,8 @@
pkgname=zsa-wally
pkgver=2.1.0
+baseSrcURL="https://github.com/zsa/wally/raw/$pkgver-linux/"
+expSrcURL="$baseSrcURL/dist/linux64"
pkgrel=1
pkgdesc="Wally: Flash your ZSA Keyboard the EZ way."
arch=('i686' 'x86_64')
@@ -10,17 +12,19 @@ license=('MIT')
depends=('gtk3' 'webkit2gtk' 'libusb')
provides=('wally')
source=("https://github.com/zsa/wally/releases/download/${pkgver}-linux/wally"
- "https://github.com/zsa/wally/blob/${pkgver}-linux/appicon.png"
- "https://github.com/zsa/wally/blob/${pkgver}-linux/dist/linux64/50-wally.rules"
- "https://github.com/zsa/wally/blob/${pkgver}-linux/dist/linux64/wally.desktop"
+ "https://github.com/zsa/wally/raw/$pkgver-linux/appicon.png"
+ "https://github.com/zsa/wally/raw/$pkgver-linux/dist/linux64/50-wally.rules"
+ "https://github.com/zsa/wally/raw/$pkgver-linux/dist/linux64/wally.desktop"
)
sha256sums=('cdb168899d4e3a81eddfcfa7746d1e4e0dab886ea043644e54339b51f396c087'
- 'SKIP'
- 'SKIP'
- 'SKIP'
+ '81df9f24859cfd19ee8128d74a72155fe222e33349c9a647da98922f3f5b7857'
+ '269c9196bc65b2e62be549e3d34e56768fe702ff099b7780a1661ca4c92a0143'
+ 'd769c63305a6a4f5aa1d661826d8c475014ef8b456e60074596e940e7901c130'
)
package() {
+ echo $baseSrcURL
+ echo $expSrcURL
install -Dm644 appicon.png "$pkgdir/usr/share/pixmaps/wally.png"
install -Dm755 wally "$pkgdir/usr/bin/wally"
install -Dm644 -t "$pkgdir/etc/udev/rules.d" 50-wally.rules