summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Patrick Fair2020-09-01 07:27:06 -0600
committerChristopher Patrick Fair2020-09-01 07:27:06 -0600
commitd77467e850a1585074aa8a7c2dda1e6062ec29aa (patch)
tree94870bc53484a11d4e7cf029dec4a90750e9e95b /PKGBUILD
parente2b52dd2ff9b40e5d4ef8e59b2972b98531d0a72 (diff)
downloadaur-d77467e850a1585074aa8a7c2dda1e6062ec29aa.tar.gz
I had to add a script that would run the wally executable with absolute path that was necessary because the bin file must be executed with absolute path instead of relying on the path
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 29fcb77596a1..7966e605d416 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=zsa-wally
pkgver=2.0.0
-pkgrel=2
+pkgrel=3
pkgdesc="Wally: Flash your ZSA Keyboard the EZ way."
arch=('i686' 'x86_64')
url="https://github.com/zsa/wally"
@@ -26,6 +26,8 @@ build() {
package() {
install -Dm644 50-wally.rules "$pkgdir"/etc/udev/rules.d/50-wally.rules
- install -Dm755 $srcdir/wally-$pkgver-linux/build/wally "$pkgdir"/usr/bin/wally
+ install -Dm755 $srcdir/wally-$pkgver-linux/build/wally "$pkgdir"/usr/bin/wally-bin
+ echo "/usr/bin/wally-bin" > "$pkgdir"/usr/bin/wally
+ chmod uag+x "$pkgdir"/usr/bin/wally
chmod -R uag+rw $srcdir
}