summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrii Burkivskyi2019-12-19 07:06:28 +0100
committerAndrii Burkivskyi2019-12-19 07:06:28 +0100
commit5fa6ae75f7fdd17d614a99dda83dac1f5866dbc6 (patch)
treea9e78a2e68b1b9ea278736f5802dffa3a41317ca /PKGBUILD
downloadaur-5fa6ae75f7fdd17d614a99dda83dac1f5866dbc6.tar.gz
added sources
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ce072f37f1f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Andrii Burkivskyi <buryk212@gmail.com>
+pkgname=zsh-extract-git
+_gitname=zsh-extract
+pkgver=r2.85ee9a2
+pkgrel=1
+pkgdesc="This plugin defines a function called extract that extracts the archive file you pass it, and it supports a wide variety of archive filetypes."
+arch=(any)
+url=https://github.com/le0me55i/zsh-extract
+license=(custom)
+depends=(zsh)
+makedepends=(git)
+provides=(zsh-extract)
+conflicts=(zsh-extract)
+source=(git+https://github.com/le0me55i/zsh-extract)
+install=zsh-extract-git.install
+sha256sum=(SKIP)
+
+pkgver() {
+ cd "$_gitname"
+ commit=$(git rev-list --count master)
+ hash=$(git rev-parse --short HEAD)
+ echo "r$commit.$hash"
+}
+
+package() {
+ cd "$_gitname"
+
+ install -Dm644 extract.plugin.zsh "$pkgdir"/usr/share/zsh/plugins/"$_gitname"/extract.plugin.zsh
+ install -Dm644 _extract "$pkgdir"/usr/share/zsh/site-functions/_extract
+ install -Dm644 README.md "$pkgdir"/usr/share/doc/"$_gitname"/README.md
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
+}